1039 Course List for Student (25 分) unorder_set数组会超时

1039 Course List for Student (25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

最开始使用unordered_set,另外别用hash_set不支持string,并且已经被unordered_set代替了,每个课程一个set<string> 保存所选课程的学生名字, 结果最后一个测试点超时。我猜测是每个同学都需要对所有的set进行一次find,所以会很耗时。最后AC是使用unordered_map<一个学生姓名,该学生选择课程的列表>,

#include <iostream>
#include <algorithm>
#include <vector>
#include <hash_set>
#include <set>
#include <queue>
#include <unordered_map>
#include <climits>
#include <hash_map>
#include <cstdlib>
#include <unordered_set>

using namespace std;



int main()
{
    int n,k;
    scanf("%d %d",&n,&k);

    unordered_map<string,vector<int>> mapp;
    for(int i=0; i<k; i++)
    {
        int index,stuNum;
        scanf("%d %d",&index,&stuNum);

        for(int m=0; m<stuNum; m++)
        {
            string name;
            name.resize(4);
            scanf("%s",&name[0]);
            mapp[name].push_back(index);
            //mapp[index].insert(name);
        }
    }
    for(int i=0; i<n; i++)
    {
        string name;
        name.resize(4);
        scanf("%s",&name[0]);
        printf("%s",name.c_str());

        if(mapp[name].size()==0)
            printf(" 0");

        else
        {
            sort(mapp[name].begin(),mapp[name].end());
            printf(" %d",mapp[name].size());

            for(int i=0; i<mapp[name].size(); i++)
            {
                printf(" %d",mapp[name][i]);

            }
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是实现该类的Python代码: ```python from typing import List class Person: def __init__(self, name: str, email: str): self.name = name self.email = email def get_info(self) -> str: return f"Name: {self.name}\nEmail: {self.email}" class Student(Person): def __init__(self, name: str, email: str): super().__init__(name, email) self.courses = [] def add_course(self, course): self.courses.append(course) def remove_course(self, course): self.courses.remove(course) def get_courses(self) -> List[str]: return [course.name for course in self.courses] def get_info(self) -> str: return f"{super().get_info()}\nCourses: {', '.join(self.get_courses())}" class Teacher(Person): def __init__(self, name: str, email: str): super().__init__(name, email) self.courses = [] def add_course(self, course): self.courses.append(course) def remove_course(self, course): self.courses.remove(course) def get_courses(self) -> List[str]: return [course.name for course in self.courses] def get_info(self) -> str: return f"{super().get_info()}\nCourses: {', '.join(self.get_courses())}" class Admin: def __init__(self): self.students = [] self.teachers = [] self.courses = [] def add_student(self, student: Student): self.students.append(student) def remove_student(self, student: Student): self.students.remove(student) def add_teacher(self, teacher: Teacher): self.teachers.append(teacher) def remove_teacher(self, teacher: Teacher): self.teachers.remove(teacher) def add_course(self, course): self.courses.append(course) def remove_course(self, course): self.courses.remove(course) class Course: def __init__(self, name: str, teacher: Teacher): self.name = name self.teacher = teacher self.students = [] def add_student(self, student: Student): self.students.append(student) def remove_student(self, student: Student): self.students.remove(student) def get_info(self) -> str: return f"Name: {self.name}\nTeacher: {self.teacher.name}\nStudents: {[student.name for student in self.students]}" # Example Usage admin = Admin() teacher = Teacher("John Smith", "[email protected]") course = Course("Math", teacher) student = Student("Jane Doe", "[email protected]") admin.add_teacher(teacher) admin.add_student(student) admin.add_course(course) course.add_student(student) teacher.add_course(course) student.add_course(course) print(student.get_info()) print(teacher.get_info()) print(course.get_info()) ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值