PAT甲级1058 A+B in Hogwarts (20分) 自己实现加法的好的思路,别使用进位变量了,麻烦的很

1058 A+B in Hogwarts (20分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).
Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

很简单的题,好像也没啥要注意的,提取数字 和 实现加法时候麻烦一点点

#include <iostream>
#include <string>
using namespace std;
#include<vector>

void get(string  str,int *a,int *b,int *c)
{
    vector<int> vec;
    for(int i=0; i<str.size(); i++)
    {
        if(str[i]=='.')
        {
            vec.push_back(i);
        }
    }
    *a=stoi(str.substr(0,vec[0]));
    *b=stoi(str.substr(vec[0]+1,vec[1]));
    *c=stoi(str.substr(vec[1]+1));
}

int main()
{
    int a1,b1,c1,a2,b2,c2;
    string str,str2;
    cin>>str>>str2;
    get(str,&a1,&b1,&c1);
    get(str2,&a2,&b2,&c2);
    int a3,b3,c3;
    int jinwei=0;

    c3=c2+c1;

    if(c3>=29)
    {
        jinwei=1;
        c3-=29;
    }
    b3=b2+b1+jinwei;
    jinwei=0;
    if(b3>=17)
    {
        jinwei=1;
        b3-=17;
    }
    a3=a2+a1+jinwei;

    cout<<a3<<'.'<<b3<<'.'<<c3;
    return 0;
}


看完柳神的代码,感觉自己脑袋瓦特了,scanf读取数字那么方便,非自己用string转int。。。。。。。。。。

欣赏下柳神代码吧,艺术
地址 https://blog.csdn.net/liuchuo/article/details/52121255

#include <iostream>
using namespace std;
int main() {
    int a1, b1, c1, a2, b2, c2, a, b, c;
    scanf("%d.%d.%d %d.%d.%d", &a1, &b1, &c1, &a2, &b2, &c2);
    c = c1 + c2;
    b = b1 + b2 + c / 29; c = c % 29;
    a = a1 + a2 + b / 17; b = b % 17;
    printf("%d.%d.%d\n", a, b, c);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值