uva 11300

这是个纯粹推理数学公式的题

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone
around a circular table. First, everyone has converted all of their properties to coins of equal value,
such that the total number of coins is divisible by the number of people in the village. Finally, each
person gives a number of coins to the person on his right and a number coins to the person on his left,
such that in the end, everyone has the same number of coins. Given the number of coins of each person,
compute the minimum number of coins that must be transferred using this method so that everyone
has the same number of coins.
Input
There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the
village. n lines follow, giving the number of coins of each person in the village, in counterclockwise
order around the table. The total number of coins will fit inside an unsigned 64 bit integer.
Output
For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input
3
100
100
100
4
1
2
5
4
Sample Output·
0
4

大致意思就是分硬币 每个人有一个初始的硬币数量
然后人都坐了一圈
每个人可以向相邻的两个人给出硬币
最后保证硬币数量相同

求 最少移动的硬币数量

首先 这是一个纯粹的数学推理

首先设人为A1

A1给出的硬币数量为x1 A2给出的为x2。。。。。。。。。

这里写图片描述

以上就是推理过程

x1为什么是等于负的c[n-2]?
为了最小

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
long long c[10000005],b[10000005],j[100005];
int main()
{
    int n;
    while(cin>>n)
    {
        int i;
        long long x=0;
        for(i=1;i<=n;i++)
        {
            cin>>b[i];
            x+=b[i];
        }
        x=x/n;

        c[0]=0;
        for(i=1;i<n;i++)
        {
            c[i]=c[i-1]+x-b[i];
        }
        sort(c,c+n); //以此确定点的顺序
        x=-c[n/2];  //然后找到中间点
        long long y=0;
        for(i=0;i<n;i++)
        {
            y=y+abs(c[i]+x);
        }
        cout<<y<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值