UVA - 11300(数学)

Spreading the Wealth

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

Input

There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3 100 100 100 4 1 2 5 4

Sample Output

0 4

题意:有n个人围成一圈,每个人手上有Ai coins。每个人可以给他旁边的人coins。题目求每个coins传递的最小次数且传递之后所以的人手上的coins相等。

思路:我们很容易可以知道最后每个人手上sum/n个coins.我们令逆时针为正方向,对于Ai流出有xi个coins,流入有x(i-1)。

则有

A1-x1+x2=sum/n

A2-x2+x3=sum/n

A3-x3+x4=sum/n

移项

x2=sum/n-A1+x1=x1-(A1-sum/n)

x3=sum/n-A2+x2=x2-(A2-sum/n)=x1-(A1-sum/n)-(A2-sum/n)

令Ci=(A1-sum/n)+(A2-sum/n)+….+(Ai-sum/n)

则有

x2=x1-C1

x3=x1-C2

….

我们要求|x1|+|x2|+…+|xn|最小,则要求|x1-Ci|最小。而Ci可以全部算出来,所以我们要确定x1的取值,而当x1取中位数时结果最小(中位数不受分布数列的极大或极小值影响)。

#include <iostream>
#include <fstream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <set>
#include <cmath>
#include <algorithm>
#include <functional>
#define inf 0x7fffffff
using namespace std;
typedef long long ll;
const int MAXN=1e5+10;
const int MAX=1e6+10;
const double eps=1e-6;

ll c[MAX],s[MAX];

int main(){
    #ifdef ONLINE_JUDGE
    #else
    freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    #endif

    int n;
    while(cin>>n){
        ll sum=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&s[i]);
            sum+=s[i];
        }
        ll m=sum/n;
        c[1]=(m-s[1]);
        for(int i=2;i<=n;i++){
            c[i]=c[i-1]+(m-s[i]);
        }
        sort(c+1,c+n+1);
        int temp;
        if(n%2==1)
            temp=c[n/2+1];
        else
            temp=(c[n/2]+c[n/2+1])/2;
        //cout<<temp<<endl;
        ll ans=0;
        for(int i=1;i<=n;i++)
            ans+=abs(temp-c[i]);
        cout<<ans<<endl;
    }

    return 0;   
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值