poj3617 Best Cow Line _贪心

 

Best Cow Line

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22701 Accepted: 6185

 

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

 

题意:简单来说,就是给定长度为N的字符串S,要构造一个长度为N的字符串T。 
*起初,T是一个空串,随后反复进行下列任意操作。
*从S的头部删除一个字符,加到T的尾部
*从S的尾部删除一个字符,加到T的尾部
*目标是要构造字典序尽可能小的字符串T。 

 

 

字典序:是指从前到后比较两个字符串大小的方法。首先比较第1个字符,如果不同则第1个字符较小的字符串更小,
如果相同则继续比较第2个字符...如此继续,来比较整个字符串的大小。 

 

 

贪心算法: 
按照字典序比较S和将S反转后的字符串S'
如果S较小,就从S的开头取出一个文字,追加到T的末尾
如果S'较小,就从S的末尾取出一个文字,追加到T的末尾(如果相同取哪个都可以) 

 

 

//
// Created by Admin on 2017/3/4 
//
#include<cstdio>

int main(){
	int n; 
	char s[2010];
	while(~scanf("%d",&n)){
		getchar();
		for(int i=0;i<n;i++){
			scanf("%c",&s[i]);
			getchar();
		}
		int count=0,a=0,b=n-1;
		while(a<=b){  //将从左起和从右起的字符串比较 
			bool left=false;  //初始化左端字符小于右端字符 
			for(int i=0;a+i<=b;i++){  //比较两端字符大小 
				if(s[a+i]<s[b-i]){   //如果左端小,则left置true,确定取左端字符,退出循环 
					left=true;
					break;
				}
				else{
					if(s[a+i]>s[b-i]){  //如果右端小,则left置false,确定取右端字符,退出循环 
						left=false;
						break;
					}	
				}
				//如果左右两端字符相同,则需比较下一个字符的大小(如ABGCA,比较B和C) 
			}
			if(left) putchar(s[a++]);  //如果S的左端字符较小,则取左端字符 
			else putchar(s[b--]);  //否则,取右端字符 
			if(++count%80==0)printf("\n");  //每输出80个字符就换行 
		}
	}
	return 0;
} 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值