POJ3617 Best Cow Line Greedy

给你一个字符串,每次两种操作将字符串重组,字典序最小。

将第一个字符加在新字符串尾部

将最后一个字符加在新串尾部


从前从后比较两个字符串字典序,选择小的第一个字符添加到新串尾部,反复如此。相同时随便选一个。不能够简单比较第一个字符。


Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5946 Accepted: 1922

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cstdio>

using namespace std;

#define MAXN 2100

char str[MAXN];
int n;

void func()
{
    int cnt=0,l=0,r=n-1;
    while(l<=r)
    {
        bool lf=1;
        for(int i=0;i+l<=r;i++)
        {
            if(str[l+i]<str[r-i])
            {
                lf=1;
                break;
            }
            else if(str[l+i]>str[r-i])
            {
                lf=0;
                break;
            }
        }

        if(lf)
            putchar(str[l++]);
        else
            putchar(str[r--]);
        cnt++;
        if(cnt==80)
        {
             printf("\n");
             cnt=0;
        }
    }
    printf("\n");
}

int main()
{
    while(cin>>n)
    {
        for(int i=0;i<n;i++) cin>>str[i];
        str[n]='\0';
        func();
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值