poj3253 Fence Repair _贪心

Fence Repair

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 45619 Accepted: 14882

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li(1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

 

题意:将一块很长的木板切割成N块。准备切成的木板的长度为L1、L2、...、Ln,
未切割前的木板长度恰好为切割后木板长度的总和。每次切断木板时,需要的开销为这块木板的长度。 

 

思路:首先,切割的方法可以参见下图的二叉树来描述。


对于最优解来讲,最短的板应当是深度最大的叶子节点之一。
所以与这个叶子节点同一深度的兄弟节点一定存在, 并且由于同样是最深的叶子节点,所以应该对应于次短的板。
不妨将Li按照大小顺序排列,那么最短的板应该是L1而次短的则是L2。
如果它们在二叉树中是兄弟节点,就意味着它们是从一块长度为(L1+L2)的木板切割得来的。
由于切割顺序是自由的,不妨当作是最后被切割。这样一来,在这次切割前就有(L1+L2),L3,L4,...,Ln  这样的N-1块木板存在。

所以递归地将这N-1块木板的问题求解,就可以求出整个问题的答案 

 

//
// Created by Admin on 2017/3/13 
//
#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
	int n,L[20020];
	while(~scanf("%d",&n)){
		for(int i=0;i<n;i++)
		   scanf("%d",&L[i]);
		long long ans=0;
		while(n>1){  //直到计算到木板为1块时为止 
			int min1=0,min2=1;
			if(L[min1]>L[min2]) swap(min1,min2);  
			for(int i=2;i<n;i++)  //求出最短的板min1和次短的板min2 
			   if(L[i]<L[min1]){
			   	   min2=min1;
			   	   min1=i;
			   }
			   else{
			   	      if(L[i]<L[min2])
			   	         min2=i;
			   }
			   
			int temp=L[min1]+L[min2];  //将两块板拼合 
			ans+=temp;
			if(min1==n-1) swap(min1,min2);  //特殊处理(目的是保持计算值temp和可能未使用的L[n-1]的值) 
			L[min1]=temp;
			L[min2]=L[n-1];
			n--;
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值