poj2431 Expedition _STL优先队列

 

Expedition

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14952 Accepted: 4191

 

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

 

/*
 * 为了到达终点时加油次数尽可能少,所以当燃料为0了之后再进行加油。
 * 在燃料为0时,选取前面已经经过的加油站中油量最大的进行加油
 */


/*
 * 在经过加油站i时,往优先队列里加入Bi
 * 当燃料空了时,
 *     如果优先队列也是空的,则无法到达终点
 *     否则取出优先队列中的最大元素,并用来给卡车加油
 */

//
// Created by Admin on 2017/3/25.
//

#include <cstdio>
#include <queue>
#include <algorithm>
#define MAX 10010
using namespace std;
int N,L,P;

struct STOP{
    int a,b;
}stop[MAX];

int cmp(STOP S1,STOP S2){
    return S1.a<S2.a;
}
int solve(){
    priority_queue<int> que;  //加油站优先队列
    int pos=0,d=0,ans=0;  //ans:加油次数 pos:现在所在位置 P:油箱中剩余油量
    for (int i = 0; i <= N; ++i) {
        d=stop[i].a-pos;  //到下一个加油站的距离
        while (P<d){  //不断加油直到油量足够行驶到下一加油站
            if(que.empty())
                return -1;
            P+=que.top();  //取前面油量最大的加油站
            que.pop();
            ans++;
        }
        pos=stop[i].a;
        P-=d;
        que.push(stop[i].b);
    }
    return ans;
}

int  main(){
    while(~scanf("%d",&N)){
        for (int i = 0; i < N; ++i)
            scanf("%d%d",&stop[i].a,&stop[i].b);
        scanf("%d%d",&L,&P);
        for (int j = 0; j < N; ++j)
            stop[j].a=L-stop[j].a;  //使a为到起点的距离
        stop[N].a=L;  //将终点视为加油站
        stop[N].b=0;
        sort(stop,stop+N,cmp);  //按加油站到起点距离由小到大排序
        printf("%d\n",solve());
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值