hdu1028 Ignatius and the Princess III _母函数

 

Ignatius and the Princess III

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20667    Accepted Submission(s): 14419

 

 

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

 

 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

 

 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

 

 

Sample Input

 

4 10 20

 

 

Sample Output

 

5 42 627

 

 

 

/*
 * 思路:开两个数组,a[]保存当前得到的多项式各项系数,b[]保存每次计算的临时结果,当每次计算完毕后,把它赋给a,然后b清零。
 * 计算时开3层循环,最外层,记录它正在与第几个多项式相乘;第二层,表示a中的每一项,第三层表示后面被乘多项式的每一项。
 * G(x)=(1+x+x^2+x^3+...)*(1+x^2+x^4+...)*(1+x^3+x^6+...)+..

 */

 

//
// Created by Admin on 2017/3/28.
//

#include <cstdio>

int main(){
    int n,a[130],b[130];
    while (~scanf("%d",&n)){
        for (int i = 0; i <= n; ++i) {
            a[i]=1;  //保存当前得到多项式的各项系数
            b[i]=0;  //保存每次计算时的临时结果
        }
        for (int i = 2; i <= n; ++i) {  //记录a正在与第几个多项式进行运算
            for (int j = 0; j <=n ; ++j) {  //a中的每一项前的系数
                for (int k = 0; k+j<=n; k+=i) {  //表示被乘多项式的每一项的系数
                    b[k+j]+=a[j];  //每次计算,把结果存入b
                }
            }
            for (int j = 0; j <= n; ++j) {
                a[j]=b[j];  //每次计算完毕后,就把它赋给a
                b[j]=0;  //然后b清零
            }
        }
        printf("%d\n",a[n]);
    }
    return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值