pojsupermark

Supermarket
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9103 Accepted: 3891

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185
题意:超市有n样东西要卖出去,每dp个花费dd单位时间可以卖出去赚得最大利润,现要求计算如何赚得最大利润。解题:将最大的先卖,卖不完的放到前一天一起卖,其中利润大的优先卖,这样一直卖到最小的时候,就能获得最大利润。因为期限小的不可能在大时间时候卖出去,而大期限的可以在小的期限时间里卖。建立一个优先队列,大的优先,用sort排序将存放数据p,d的数组ans从大到小排好序。压入队列,使得最大的利润被压出。
#include<cstdio>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
#define N 10005
typedef struct nnn
{
    int p,d;
}node;
typedef struct nn
{
    int p;
    friend bool operator<(struct nn a,struct nn b)//优先队列值从大到小取
    {
        return a.p<b.p;
    }
}INT;
node ans[N];
int cmp(node a,node b)//最后期限从大到小排
{
    return a.d>b.d;
}
int solve(int n,int l)
{
    int maxp=0,tl,d,i,maxd;
    priority_queue<INT>q;
    INT pp;
    i=0;
    for(maxd=ans[0].d; maxd>0;maxd--)
    {
        for( ;i<n&&maxd<=ans[i].d; i++)
        {
            pp.p=ans[i].p; q.push(pp);
        }
        tl=0;
        while(!q.empty()&&tl<l)
        {
            pp=q.top(); q.pop();
            maxp+=pp.p; tl++;
        }
    }
    return maxp;
}
int main()
{
    int n,l,i;
  while(scanf("%d",&n)>0)
    {
        for( i=0;i<n;i++)
            scanf("%d%d",&ans[i].p,&ans[i].d);
        if(n==0)
        {
            printf("0\n"); continue;
        }
        sort(ans,ans+n,cmp);
        printf("%d\n",solve(n,1));
    }
}
内容概要:该题库专为研究生入学考试计算机组成原理科目设计,涵盖名校考研真题、经典教材课后习题、章节题库和模拟试题四大核心模块。名校考研真题精选多所知名高校的计算机组成原理科目及计算机联考真题,并提供详尽解析,帮助考生把握考研命题趋势与难度。经典教材课后习题包括白中英《计算机组成原理》(第5版)和唐朔飞《计算机组成原理》(第2版)的全部课后习题解答,这两部教材被众多名校列为考研指定参考书目。章节题库精选代表性考题,注重基础知识与重难点内容,帮助考生全面掌握考试大纲要求的知识点。模拟试题依据历年考研真题命题规律和热门考点,精心编制两套全真模拟试题,并附标准答案,帮助考生检验学习成果,评估应试能力。 适用人群:计划参加研究生入学考试并报考计算机组成原理科目的考生,尤其是需要系统复习和强化训练的学生。 使用场景及目标:①通过研读名校考研真题,考生可以准确把握考研命题趋势与难度,有效评估复习成效;②通过经典教材课后习题的练习,考生可以巩固基础知识,掌握解题技巧;③通过章节题库的系统练习,考生可以全面掌握考试大纲要求的各个知识点,为备考打下坚实基础;④通过模拟试题的测试,考生可以检验学习成果,评估应试能力,为正式考试做好充分准备。 其他说明:该题库不仅提供详细的题目解析,还涵盖了计算机组成原理的各个方面,包括计算机系统概述、数据表示与运算、存储器分层、指令系统、中央处理器、总线系统和输入输出系统等。考生在使用过程中应结合理论学习与实践操作,注重理解与应用,以提高应试能力和专业知识水平。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值