poj1847Tram

Tram
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14404 Accepted: 5322
Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.
Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.
Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.
Sample Input

3 2 1
2 2 3
2 3 1
2 1 2
Sample Output

0
Source
题意很难啊,看得我尴尬症都犯了,给你一个图,要到达一个点,下面点是这样的,第一个值代表点的方向数,第二个值代表一个不用转的方向,后面代表需要转的方向。由此我们可以标记第二个值map[i][j]=0,后面的全部标记map[i][j]=1;然后我用三种方式都写了一遍,直接调用函数模板就行了

#include <cstdio>
#include <queue>
#include <iostream>
#include <cstring>
#include <algorithm>
#define N 105
using namespace std;
const int inf=0x3f3f3f3f;
int map[N][N];
int n,a,b;
void floyed()
{
    int i,j,k;
    for(k=1; k<=n; k++)
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                if(map[i][j]>map[i][k]+map[k][j])
                    map[i][j]=map[i][k]+map[k][j];
            }
}
/*int main()
{
    int a,b;
    int i,j;
    memset(map,0,sizeof(map));
    while(scanf("%d%d%d",&n,&a,&b)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            map[i][i]=0;
            int t;
            scanf("%d",&t);
            if(!t) continue;
            int temp;
            scanf("%d",&temp);
            map[i][temp]=0;
            for(j=1;j<t;j++)
            {
                scanf("%d",&temp);
                map[i][temp]=1;
            }
        }
        floyed();
        if(map[a][b]==inf)
        cout<<"-1"<<endl;
        else
        cout<<map[a][b]<<endl;
    }
}*/
int d[N],vist[N];
int spfa()
{
    int i;
    for(i=1; i<=n; i++)
    {
        vist[i]=0;
        d[i]=inf;
    }
    vist[a]=1;
    d[a]=0;
    queue<int>q;
    q.push(a);
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        vist[now]=0;
        for(i=1; i<=n; i++)
        {
            if(d[i]>d[now]+map[now][i])
            {
                d[i]=d[now]+map[now][i];
                if(!vist[i])
                {
                    vist[i]=1;
                    q.push(i);
                }
            }
        }
    }
    return d[b];
}
void Dijkstra()
{
    memset(vist,false,sizeof(vist)); //清除所有的点
    for(int i=1; i<=n; i++)
        d[i] = map[a][i];

    d[a] = 0;
    vist[a] = 1; //标记起点

    for(int i=1; i<=n; i++) //循环n 次
    {
        int x, m =inf;
        for(int y = 1; y <= n; y++) //在所有未标号的节点中,选出dist值的最小点x
            if(!vist[y] && d[y] <= m)
                m = d[x=y];
        vist[x] = 1;//给节点 x 标记
        for(int y = 1; y <= n; y++)//更新  松弛操作
            d[y] = min(d[y],d[x]+map[x][y]);

    }
    if(d[b] == inf) printf("-1\n");
    else printf("%d\n", d[b]);
}
int main()
{
    int i,j,k,t;
    memset(map,0,sizeof(map));

    while(scanf("%d%d%d",&n,&a,&b)!=EOF)
    {
        for(i=1; i<=n; i++)
        {
            d[i]=inf;
            for(j=1; j<=n; j++)
                map[i][j]=inf;
        }
        for(i=1; i<=n; i++)
        {
            scanf("%d",&k);
            for(j=1; j<=k; j++)
            {
                scanf("%d",&t);
                if(j==1)
                    map[i][t]=0;
                else
                    map[i][t]=1;
            }
        }
        spfa();
        if(d[b] == inf) printf("-1\n");
        else printf("%d\n", d[b]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值