hdu3605Escape

Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/65536K (Java/Other)
Total Submission(s) : 10 Accepted Submission(s) : 4
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.

Input
More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000

Output
Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.

Sample Input
1 1
1
1

2 2
1 0
1 0
1 1

Sample Output
YES
NO
2012末日到了,要你吧人们迁移到星球,有n个人,m个星球,每个人有m个对星球的适应性,每个星球有最大人数规定,问是否能全部转移。
对每个星球,有多少人能搬,就用数组link[i][j],第i个星球j人,num[i]记录人数,然后直接枚举所有num个星球和人的最大匹配,如果flag为1,则匹配成功。注意link的人数里面最开始要++num[i]

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define N 100005
#define M 12
using namespace std;
int map[N][M];
int vist[M],link[M][N];
int num[M],cap[M];
int n,m;
int find(int v)
{
    for(int i=1;i<=m;i++)
    {
        if(map[v][i]&&!vist[i])
        {
            vist[i]=1;
            if(num[i]<cap[i])
            {
                link[i][++num[i]]=v;
                return 1;
            }
            for(int j=1;j<=num[i];j++)
            {
                if(find(link[i][j]))
                {
                    link[i][j]=v;
                    return 1;
                }
            }
        }
    }
    return 0;
}

/*int solve()
{
    int i;
    int flag;
    memset(num,0,sizeof(num));
    for(i=1; i<=n; i++)
    {
        memset(vist,0,sizeof(vist));
        if(!find(i))
        {
            flag=0;
            break;
        }
    }
    return flag;
}*/
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&map[i][j]);
        for(int i=1;i<=m;i++)
            scanf("%d",&cap[i]);
        memset(num,0,sizeof(num));
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            memset(vist,0,sizeof(vist));

            if(!find(i))
            {
                flag=1;
                break;
            }
        }
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值