hdu 1198 Farm Irrigation

Farm Irrigation
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 6 Accepted Submission(s) : 4
Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like

Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A’ to ‘K’, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output
For each test case, output in one line the least number of wellsprings needed.

Sample Input
2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output
2
3

题意:给你一个数字拼图,里面包含四个可连的方向,问在给定的图片中,拼出几个集合
处理方向,用数组dir 装住十一个方向,刚开始建方向建大了,本以为结构体简单得多。。。
然后分别在横和竖两个方向进行并合,初始集合为n,每发现一个可以合并的点,n–,最后输出剩下的就是合并后的集合数

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#define N 550
using namespace std;
int n,m,ans;
char s[N][N];
int map[N*N+5];
int dir[11][4]={{1,1,0,0},{0,1,1,0},
                        {1,0,0,1},{0,0,1,1},
                        {0,1,0,1},{1,0,1,0},
                        {1,1,1,0},{1,1,0,1},
                        {1,0,1,1},{0,1,1,1},
                        {1,1,1,1}
                        };


void init(int n)
{
    int i;
    for(i=1;i<=n;++i)
    map[i]=i;
    ans=n;
}
/*void solve()
{
    int i,j;
    for(i=1;i<n;i++)
    {
        for(j=1;j<=m;j++)
        {
            int k=0;
            vist[i][j]=0;
            if(s[i][j]=='A')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='B')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='C')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='D')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='E')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='F')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='G')
            { 
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='H')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='I')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='J')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
            else if(s[i][j]=='K')
            {
                now[i][j].z=1;
                now[i][j].y=0;
                now[i][j].s=1;
                now[i][j].x=0;
            }
        }
    }
}*/
int vist=1;
int find(int x)
{
    if(x!=map[x])
    map[x]=find(map[x]);
    return map[x];
}
void Union(int ax,int ay,int bx,int by,bool flag)
{
    if(bx>n || by>m)
    return;
    bool mark = false;
    int ta,tb;

    ta = s[ax][ay]-'A';
    tb = s[bx][by]-'A';

    if(flag){//竖直方向
        if(dir[ta][3] && dir[tb][1])
        mark = true;
    }else{//水平方向
        if(dir[ta][2] && dir[tb][0])
        mark = true;
    }

    if(mark){
        int fx = find((ax-1)*m+ay);
        int fy = find((bx-1)*m+by);
        if(fx!=fy)
        {
            map[fy] = fx;
            --ans;
        }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF&&n!=-1&&m!=-1)
    {
        init(n*m);
        for(int i=1;i<=n;++i)
        scanf("%s",s[i]+1);
        for(int i=1;i<=n;++i)
        {
            for(int j=1;j<=m;++j)
            {
                Union(i,j,i+1,j,vist);//s
                Union(i,j,i,j+1,!vist);//x
            }
        }
        cout<<ans<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值