UVA10881蚂蚁

“One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords.”
Kent Brockman
Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing
either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they
both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each
of the ants starts and which direction it is facing and wants to calculate where the ants will end up T
seconds from now.
Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line
containing 3 integers: L , T and n (0 ≤ n ≤ 10000). The next n lines give the locations of the n ants
(measured in cm from the left end of the pole) and the direction they are facing (L or R).
Output
For each test case, output one line containing ‘Case #x:’ followed by n lines describing the locations
and directions of the n ants in the same format and order as in the input. If two or more ants are at
the same location, print ‘Turning’ instead of ‘L’ or ‘R’ for their direction. If an ant falls off the pole
before T seconds, print ‘Fell off’ for that ant. Print an empty line after each test case.
Sample Input
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Sample Output
Case #1:
2 Turning
6 R
2 Turning
Fell off
Case #2:
3 L
6 R
10 R
模拟蚂蚁走路

#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
#define maxn 10005
struct node
{
    int id;//输入顺序
    int p;//位置
    int d;//朝向  -1:左, 0:转身中, 1:右。
    bool operator < (const node& a) const
    {
        return p < a.p;//按P升序
    }
}before[maxn], after[maxn];
int order[maxn];//输入的第i只蚂蚁是终态中的左数第order[i]只蚂蚁
const char dir[][10]= {"L","Turning","R"};
int main()
{
    int ncs;
    cin >> ncs;
    for (int t = 1; t <= ncs; ++t)
    {
        int L, T, n;
        scanf ("%d %d %d", &L, &T, &n);//输入木棍长度,走的时间,蚂蚁的数量
        int p, d;
        char c;
        for (int i = 0; i < n; ++i)
        {
            scanf("%d %c", &p, &c);//输入蚂蚁所在位置和朝向
            d = (c == 'L' ? -1 : 1);//给d赋值,-1朝左,1朝右
            before[i] = (node){i, p, d};//相当于before[i].id = i;before[i].p = p;before[i].d = d
            after[i] = (node){0, p+T*d, d};//id是不知道的所以都用0
        }

        sort(before, before+n);
        for(int i = 0; i < n; ++i)
        {
            order[before[i].id] = i;//给order数组赋值
        }

        sort(after, after+n);//算最终的状态
        for(int i = 0; i < n; ++i)
        {
            if(after[i].p == after[i+1].p)//发生碰撞的蚂蚁
                after[i].d = after[i+1].d = 0;//方向发生改变
        }

        printf ("Case #%d:\n", t);

        for(int i = 0; i < n; ++i)
        {
            if(after[order[i]].p < 0 || after[order[i]].p > L) //掉下去的蚂蚁的判断
                printf("Fell off\n");

            else
                printf("%d %s\n", after[order[i]].p, dir[after[order[i]].d+1]);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值