Who Gets the Most Candies?

Who Gets the Most Candies?
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 14006 Accepted: 4432
Case Time Limit: 2000MS
Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (−A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.
Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1
Sample Output

Sam 3
Source

寻找的糖果数为该数的反素数的因子数;所以:
直接从第一个开始推,在i循环到s[i]<=n时,i的最大值就是所得到糖果最多的值,由于存在顺时针和逆时针,所以有顺时针k = ((k + val[pos] - 2)%n + n)%n + 1;,逆时针k = ((k + val[pos] - 1)%n + n)%n + 1;

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
//反素数打表
int s[40] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,500001
            };
//因子数打表
int b[40] = {1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,1314521};
int k,n;
char name[500111][11];
int val[500111];
struct tree
{
    int l,r,n;
} a[2000000];
void build(int l,int r,int i)
{
    a[i].l=l;
    a[i].r = r;
    a[i].n = r-l+1;
    if(l!=r)
    {
        int mid = (l+r)>>1;
        build(l,mid,i<<1);
        build(mid+1,r,i<<1|1);
    }
}
int insert(int i,int x)
{
    a[i].n--;
    if(a[i].l == a[i].r)
    {
        return a[i].l;
    }
    if(x<=a[i<<1].n)
        insert(i<<1,x);
    else
        insert(i<<1|1,x-a[i<<1].n);
}
int main()
{
    int i,j,maxn,p,pos;
    while(~scanf("%d%d",&n,&k))
    {
        i = 0;
        while(s[i]<=n)i++;//第P个出队的必然是最多,最早出队的
        maxn = b[i-1];
        p = s[i-1];
        for(i = 1; i<=n; i++)
            scanf("%s%d",name[i],&val[i]);
        build(1,n,1);
        while(p--)
        {
            n--;
            pos = insert(1,k);//出队的序号
            if(!n)
                break;
            if(val[pos]>=0)
                k = ((k + val[pos] - 2)%n + n)%n + 1;
            else
                k = ((k + val[pos] - 1)%n + n)%n + 1;
        }
        printf("%s %d\n",name[pos],maxn);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值