hdu1520Anniversary party(数形dp)

Anniversary party
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10521 Accepted Submission(s): 4412

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output
Output should contain the maximal sum of guests’ ratings.

Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5

求不选取父子节点的情况下,选取尽量大的点集

树形dp经典,将父子结点标记,然后找到根节点,再动态规划,
递推方程:
dp[root][0]+=max(dp[val][1],dp[val][0]);
dp[root][1]+=dp[val][0];
0为不选取当前点,其子树集合
1为选取当前点,其子树集合

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int MAXN=6050;
vector<int>vec[MAXN];
int f[MAXN];
int hap[MAXN];
int dp[MAXN][2];///dp[i][0]表示使用当前父节点,其下所以的子树权值和,dp[i][1]为不包括当前结点,其下子树的和
int dfs(int root)
{
    int len=vec[root].size();///容器大小
    dp[root][1]=hap[root];///使用根节点时值为根节点的权值
    for(int i=0;i<len;i++)
        dfs(vec[root][i]);
    for(int i=0;i<len;i++)
    {
        int val=vec[root][i];
        dp[root][0]+=max(dp[val][1],dp[val][0]);
        dp[root][1]+=dp[val][0];
    }
    return max(dp[root][0],dp[root][1]);
}

int main()
{
    int n;
    int a,b;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&hap[i]);
            vec[i].clear();
            f[i]=-1;//树根标记
            dp[i][0]=dp[i][1]=0;
        }
        while(scanf("%d%d",&a,&b)!=EOF&&a)
        {
            f[a]=b;
            vec[b].push_back(a);
        }
        a=1;
        for(int i=1; i<=n; i++)
            if(f[a]!=-1)
                a=f[a];//找到树根
        //dfs(a);
        //cout<<a<<"<---"<<endl;
        printf("%d\n",dfs(a));


    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值