hdu6043KazaQ's Socks(高校1)

KazaQ’s Socks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1149 Accepted Submission(s): 684

Problem Description
KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k-th day.

Input
The input consists of multiple test cases. (about 2000)

For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input
3 7
3 6
4 9

Sample Output
Case #1: 3
Case #2: 1
Case #3: 2

例子 3 7
则会出现:1 2 3 1 2 1 3 1 2 1 3 1 2 1 3 1 2 1 3……………….

例子:4 6
出现:1 2 3 4 1 2 3 1 2 4 1 2 3 1 2 4 1 2 3 1 2 4.。。。。。

/*
所以得出规律,当k<n时,直接输出k,当k>=n时,k去掉前n个,也就是第一次到循环点的袜子数,然后剩下的数量取余n-1,如果得到0,且除以n-1刚好为奇数那么证明k刚好在剩下的袜子循环点上,则直接输出n-1,刚好取余且为偶数则输出n,其余输出除出来的值取余n-1

*/
#include <iostream>
#define LL long long
using namespace std;
int main()
{
    LL n,k;
    LL ca=1;
    while(cin>>n>>k)
    {
        cout<<"Case #"<<ca++<<": ";
        if(k<=n)
            cout<<k<<endl;
        else
        {
            k-=n;
            LL t=2*(n-1);
            LL tem=n-1;
            LL m=k%t;
            if(m==0)
                cout<<n<<endl;
            else if(m==tem)
            {
                cout<<n-1<<endl;
            }
            else
            {
                cout<<m%tem<<endl;
            }
        }
    }
    //cout<<0<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值