poj---1006

Biorhythms
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 132161 Accepted: 42161
Description


Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 
Input


You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.
Output


For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 


Case 1: the next triple peak occurs in 1234 days. 


Use the plural form ``days'' even if the answer is 1.
Sample Input


0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
Sample Output


Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.
Source


East Central North America 1999




题意就是:人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。让你求出下一次三个生理周期同时出现峰值的天数。


题解:

由题目中给出的几个变量,可以由中国剩余定理可以推出一个规律:其中把距离下一次周期峰值的天数设为sum,则 根据已给的p,e,i,d可以得到三个式子:
( sum + d ) % 23 == p; 
( sum + d ) % 28 == e; 
( sum + d ) % 33 == i;
为了方便,令x=sum+d,则:

x%23==p;
x%28==e;
x%33==i;
接下来就是利用中国剩余定理来解决:
33*28*a%23=1,得a=6;   33*28*6=5544;
23*33*b%28=1,得b=9;  23*33*19=14421;
23*28*c%33=1,得c=2;  23*28*2=1288;

x=5544*p+14421*e+1288*i;
所以x-d就是相差的天数,根据题目给的范围(x-d)%=21252;并且当x<=0时,那么(x-d)+=21252,都是在这个范围内。


#include<stdio.h>
#define MAX 21252
int main()
{
    int p, e, i, d, n, count = 0;
    while( scanf("%d%d%d%d", &p, &e, &i, &d) != EOF )
    {
        count++;
        if(p == -1 && e == -1 && i == -1 && d == -1)
        {
            break;
        }
        n = ( 5544 * p + 14421 * e + 1288 * i - d ) % MAX;
        if( n <= 0 )
        {
            n += 21252;
        }
        printf("Case %d: the next triple peak occurs in %d days.\n", count, n );
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值