poj--3278Catch That Cow(搜索)

Catch That Cow


Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 84880 Accepted: 26651 点击打开链接

Description


Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.


* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.


If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?


Input


Line 1: Two space-separated integers: N and K
Output


Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input


5 17
Sample Output


4
Hint


The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source


USACO 2007 Open Silver

题意:这道题的意思是:在一条线上有两个点n,k;其中从n点往前走(即k点走),有两种方法:

1、走一步距离1m(可以往前,可以往后),一秒

2、走2*1m(可以往前,可以往后),一秒

问:花费时间最少。

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;
const int N=1000000;
int map[N+10];
int n,k;
struct node{
int x,step;
};

int check(int x)
{
    if(x<0||x>=N||map[x])
        return 0;
    return 1;
}

int bfs(int x)
{
    int i;
    queue<node>Q;
    node a,next;
    a.x=x;
    a.step=0;
    map[x]=1;
    Q.push(a);
    while(!Q.empty())
    {
        a=Q.front();
        Q.pop();
        if(a.x==k)
            return a.step;
        next=a;
        next.x=a.x+1;
        if(check(next.x))
        {
            next.step=a.step+1;
            map[next.x]=1;
            Q.push(next);
        }
        next.x=a.x-1;
        if(check(next.x))
        {
            next.step=a.step+1;
            map[next.x]=1;
            Q.push(next);
        }

        next.x=a.x*2;
        if(check(next.x))
        {
            next.step=a.step+1;
            map[next.x]=1;
            Q.push(next);
        }
    }
    return -1;
}

int main()
{
    int ans;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(map,0,sizeof(map));
        ans=bfs(n);
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值