hdu 2612

Find a way


Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12932    Accepted Submission(s): 4141




Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 


Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 


Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 


Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#
 


Sample Output
66
88
66
 


Author

yifenfei


#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
int dir[4][2]={1,0, -1,0, 0,1, 0,-1};


int ori[211][211];
int map[211][211];
int x_s1,y_s1;
int x_s2,y_s2;
int n,m;


int ans[211][211];


struct node
{
	int x,y;
	int step;
};


int min(int a,int b)
{
	return a>b?b:a;
}
int judge(int x,int y)
{
	if(x<0 || x>=n || y<0 || y>=m)	return 1;
	if(map[x][y]==1)	return 1;
	return 0;
}


void BFS(int x,int y)
{
	queue<node>q;
	node cur,next;
	int i;


	cur.x=x;
	cur.y=y;
	cur.step=0;


	map[cur.x][cur.y]=1;
	q.push(cur);
	while(!q.empty())
	{
		cur=q.front();
		q.pop();
		if(ori[cur.x][cur.y]==2)	ans[cur.x][cur.y]+=cur.step;
		for(i=0;i<4;i++)
		{
			next.x=cur.x+dir[i][0];
			next.y=cur.y+dir[i][1];


			if(judge(next.x,next.y))	continue;
			next.step=cur.step+1;
			map[next.x][next.y]=1;
			q.push(next);
		}
	}
}


int main()
{
	int i,l;
	char str[211];
	int Ans;


	while(scanf("%d%d",&n,&m)!=-1)
	{
		memset(ori,0,sizeof(ori));
		memset(ans,0,sizeof(ans));
		for(i=0;i<n;i++)
		{
			scanf("%s",str);
			for(l=0;str[l];l++)
			{
				if(str[l]=='Y')		{x_s1=i;y_s1=l;}
				else if(str[l]=='M'){x_s2=i;y_s2=l;}
				else if(str[l]=='.')ori[i][l]=0;
				else if(str[l]=='#')ori[i][l]=1;
				else if(str[l]=='@')ori[i][l]=2;
			}
		}


		for(i=0;i<n;i++)
		for(l=0;l<m;l++)
			map[i][l]=ori[i][l];
		BFS(x_s1,y_s1);


		for(i=0;i<n;i++)
		for(l=0;l<m;l++)
			map[i][l]=ori[i][l];
		BFS(x_s2,y_s2);


		Ans=11111111;
		for(i=0;i<n;i++)
		{
			for(l=0;l<m;l++)
			{
				if(ans[i][l])
				{
					Ans=min(Ans,ans[i][l]);
				}
			}
		}
		printf("%d\n",Ans*11);
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值