poj 1988(并查集)Cube Stacking

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 24968 Accepted: 8740
Case Time Limit: 1000MS
Description


Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 


Write a program that can verify the results of the game. 
Input


* Line 1: A single integer, P 


* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 


Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 
Output


Print the output from each of the count operations in the same order as the input file. 
Sample Input


6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output


1
0
2
Source


USACO 2004 U S Open


题意:
有一些碟子,有两种操作,一是把x所在堆的所有碟子都叠到y所在的碟子上,二是询问x所下面有多少个碟子。


思路:
这是一道带权的并查集,跟之前做的差不多。设两个权值cnt[x]代表以x为根结点的堆碟子的个数,dist[x]表示x这碟子到根结点的距离。求x下面有多少碟子就等于cnt[pa[x]] - dist[x] - 1;


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int M = 30005;
int pa[M],cnt[M],dist[M];
void Init()
{
    for (int i = 1;i <= M;i ++)
        pa[i] = i,cnt[i] = 1,dist[i] = 0;
}

int findset (int x)
{
    if (x != pa[x])
    {
        int root = findset (pa[x]);
        dist[x] += dist[pa[x]];
        return pa[x] = root;
    }
    else return x;
}
void Unin(int a,int b)
{
    int af = findset (a);
    int bf = findset (b);
    pa[bf] = af;
    dist[bf] = cnt[af];
    cnt[af] += cnt[bf];
}
int main ()
{
    int m,x,y;
    char op[3];
    while (~scanf ("%d",&m))
    {
        Init();
        while (m --)
        {
            scanf ("%s",op);
            if (op[0] == 'M')
            {
                scanf ("%d%d",&x,&y);
                Unin(x,y);
            }
            else
            {
                scanf ("%d",&x);
                int af = findset (x);
                printf ("%d\n",cnt[af]-dist[x]-1);
            }


        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值