并查集基础练习

A - Cube Stacking

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube.Farmer John asks Betsy to perform P (1<= P <= 100,000) operation.There are two types of operations:
moves and counts.

  • In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
  • In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

  • Line 1: A single integer, P

  • Lines 2…P+1: Each of these lines describes a legal operation.Line 2 describes the first operation, etc.Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation.For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file.No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2
子旭学长的题解:https://blog.csdn.net/Yang_1998/article/details/89684547

毛学姐的代码

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 3e4;

struct node  {
    int fa, dis;
}bcj[N + 5];

node Find(int x)
{
    node ret;
    if(bcj[x].fa < 0) {
        ret.fa = x;
        ret.dis = 0;
        return ret;
    }
    ret = Find(bcj[x].fa);
    ret.dis += bcj[x].dis;
    bcj[x] = ret;
    return ret;
}

void Union(int x, int y)
{
    x = Find(x).fa, y = Find(y).fa;
    if(x == y) return;
    bcj[x].dis = - bcj[y].fa;
    bcj[y].fa += bcj[x].fa;
    bcj[x].fa = y;
}

inline void init()
{
    for(int i = 0; i < N; ++i) {
        bcj[i].fa = -1;
        bcj[i].dis = 0;
    }
}

int main()
{
    int n, x, y;
    char op;
    init();
    cin >> n;
    for(int i = 0; i < n; ++i) {
        cin >> op;
        if(op == 'M') {
            cin >> x >> y;
            Union(x, y);
        }
        if(op == 'C') {
            cin >> x;
            cout << Find(x).dis << endl;
        }
    }
    return 0;
}

C - Ubiquitous Religions

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

我的代码

出了一点状况,注意并查集的下标不是从0开始的

#include <stdio.h>
#include <string.h>
const int N = 5e4;

int bcj[N + 5];

int Find(int x)//找到此结点的根结点,并进行路径压缩,将递归过的结点的父节点都变成根节点
{
    if(bcj[x] < 0) 
		return x;//如果小于0,表示是根节点,那么就返回
    return bcj[x] = Find(bcj[x]);//如果不是,继续向下递归
}

void Union(int x, int y)//合并两个集合
{
    x = Find(x), y = Find(y);//查找两集合的根节点
    if(x == y) 
		return;
    bcj[x] += bcj[y];//让x成为新集合的根节点
    bcj[y] = x;//让新集合的根节点成为y的根节点
}

void init()
{
	memset(bcj, -1, sizeof bcj);
}

int main()
{
	int Case = 0;
	int n, m, x, y;
	while (scanf("%d%d", &n, &m) != EOF && n && m)
	{
		init();
		while (m--)
		{
			scanf("%d%d", &x, &y);
			Union(x, y);	//两两合并
		}
		int ans = 0;
		for(int i = 1; i <= n; i++)
		{
			if (bcj[i] < 0)//如果小于0,表示是根结点,数目加一
				ans++;
		}
		printf("Case %d: %d\n", ++Case, ans);
	}
	return 0;
}

学姐的代码

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int N = 1e6;

int n, m;
int bcj[N + 5];


int Find(int x)
{
    if(bcj[x] < 0) return x;
    return bcj[x] = Find(bcj[x]);
}

void Union(int x, int y)
{
    x = Find(x), y = Find(y);
    if(x == y) return ;
    bcj[x] += bcj[y];
    bcj[y] = x;
}

int main()
{
    int Case = 0;
    int x, y;
    while(cin >> n >> m, n) {
        memset(bcj, -1, sizeof bcj);
        for(int i = 0; i < m; ++i) {
            cin >> x >> y;
            Union(x, y);
        }
        int tot = 0;
        for(int i = 1; i <= n; ++i) {
            if(bcj[i] < 0) tot++;
        }
        printf("Case %d: %d\n", ++Case, tot);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值