Chinese Girls' Amusement

Chinese Girls' Amusement 

You must have heard that the Chinese culture is quite different from that of Europe or Russia. So some Chinese habits seem quite unusual or even weird to us.

So it is known that there is one popular game of Chinese girls. N girls stand forming a circle and throw a ball to each other. First girl holding a ball throws it to the K-th girl on her left (1 <= K <= N/2). That girl catches the ball and in turn throws it to the K-th girl on her left, and so on. So the ball is passed from one girl to another until it comes back to the first girl. If for example N = 7 and K = 3, the girls receive the ball in the following order: 1, 4, 7, 3, 6, 2, 5, 1.

To make the game even more interesting the girls want to choose K as large as possible, but they want one condition to hold: each girl must own the ball during the game.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.


The output format consists of N output blocks. There is a blank line between output blocks.


Input


Input file contains one integer number N (3 <= N <= 10^2000) - the number of Chinese girls taking part in the game.


Output


Output the only number - K that they should choose.

Sample Input


2



7


6


Sample Output


3


1



题意:这道题的意思就是,给你一个数n,代表有n个人,然后从1-n传递一个气球,最后传到自己的手中,可以一次传k个人,其中k<=n/2.

如果k值有多个,那么求出最大的那个。

题解:高精度除法。找到与N互质的最大整数K即可。当N为奇数时,(N-1)/2即为所求数;当N为偶数时,如果N/2 - 1是奇数,则为所求结果,如果为偶数,N/2 - 2为所求结果。用gcd(a,b)=gcd(b,a % b)即可证明。



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int text(string a){
    int len=a.length();


    if(a[len-1]=='0' || a[len-1]=='2' || a[len-1]=='4' || a[len-1]=='6'|| a[len-1]=='8')
        return 1;
    else
        return 0;

}
string sub(string a,string b){
     int i,j,k,s,flag=1;
     int tmpa[10000],tmpb[10000],c[10000];
     string ans;
     if(a.size()<b.size()|| (a.size()==b.size() && a.compare(b)<0)){
        string tmp =a;
        a=b;
        b=tmp;
        flag=0;
     }
     while(a.length()>b.length()) b='0'+b;
     int len=a.length();
     for(i=0;i<len;i++)
     {
        tmpa[i]=a[i]-'0';
        tmpb[i]=b[i]-'0';
     }
     for(i=len-1;i>=0;i--){
        if(tmpa[i]>=tmpb[i])
            c[i]=tmpa[i]-tmpb[i];
        else{
            c[i]=10+tmpa[i]-tmpb[i];
            tmpa[i-1]--;
        }
     }
     for(i=0;i<len-1;i++)
        if(c[i]!=0)
            break;
        for(j=i;j<len;j++)
            ans=ans+(char)(c[j]+'0');
        if(!flag)
            ans='-'+ans;
        return ans;

}
string division(string str,int x){
   string ans="";
   int len=str.length();
   int y=0;
   for(int i=0;i<len;i++){
    ans+=char((y*10+(str[i]-'0'))/x+'0');
    y=(y*10+(str[i]-'0') )%x;
   }
   while(*(ans.begin())=='0' && ans.size()>1)
      ans.erase(ans.begin());
   return ans;
}
int main()
  {
     string s,s1,s2;
     int t,l;
     scanf("%d",&t);
     while(t--){
       // printf("t=%d\n",t);
        cin>>s;
        //printf("t=%d\n",text(s));
        if(text(s)==1){
             s1=division(s,2);
           //  cout<<"s1="<<s1<<endl;
            if(text(s1)==1){
                 s2=sub(s1,"1");
            }
            else{
                s2=sub(s1,"2");
            }
        }
        else{
            //printf("ok\n");
            s1=sub(s,"1");
            //cout<<"s1="<<sub(s,"1")<<endl;
            s2=division(s1,2);
        }

        if(t==0){
             cout<<s2<<endl;
        }
        else{
            cout<<s2<<endl;
            cout<<endl;
        }

     }

  }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值