ACdream 1210 Chinese Girls' Amusement 大数+思维

题目描述:

Description
You must have heard that the Chinese culture is quite different from that of Europe or Russia. So some Chinese habits seem quite unusual or even weird to us.
So it is known that there is one popular game of Chinese girls. N girls stand forming a circle and throw a ball to each other. First girl holding a ball throws it to the K-th girl on her left (1 ≤ K ≤ N/2). That girl catches the ball and in turn throws it to the K-th girl on her left, and so on. So the ball is passed from one girl to another until it comes back to the first girl. If for example N = 7 and K = 3, the girls receive the ball in the following order: 1, 4, 7, 3, 6, 2, 5, 1.
To make the game even more interesting the girls want to choose K as large as possible, but they want one condition to hold: each girl must own the ball during the game.
Input
Input contains one integer number N (3 ≤ N ≤ 10 2000) — the number of Chinese girls taking part in the game.
Output
Output the only number — K that they should choose.
Sample Input

7
6

Sample Output

3
1

题目分析:

一个n个人的圈子,从1号开始,将物品传递给左手边的第k个人 (1 ≤ K ≤ N/2),要求每个人都能传递一遍,且仅传递一遍。球最大的k值。
这个题其实是个思维题,也就是找规律,推导一下n的不同情况,就能容易的得出一个结论。
1、若n是奇数,k=n/2;
2、若n是不能被4整除的偶数,k=n/2-2;
3、若n是能被4整除的偶数,k=n/2-1;
然后这个题需要用到大数,因为n是一个10^2000的数,这里的大数运算也很简单,只需要用到大数与小数的除法和减法。

代码如下:

#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>

using namespace std;

int num[2010];
char s[2010];
int *p;
int len;

int* div(int* num)
{
    for(int i=0; i<len; i++)
    {
        if (num[i]&1) num[i+1]+=10;
        num[i]>>=1;
    }
    num[len]=0;
    while(*num==0)
    {
        len--;
        num++;
    }
    return num;
}

int* sub(int* num)
{
    int last=len-1;
    while(num[last]==0)
    {
        num[last]=9;
        last--;
    }
    num[last]--;
    while(*num==0)
    {
        len--;
        num++;
    }
    return num;
}

int main()
{
    while(scanf("%s",s)!=-1)
    {
        len=strlen(s);
        for(int i=0; i<len; i++)
        {
            num[i]=s[i]-'0';
        }
        if (num[len-1]&1) p=div(num);//奇数
        else
        {
            p=div(num);
            p=sub(p);
            if ((p[len-1]&1)==0) p=sub(p);//不能被四整除的偶数
        }
        for(int i=0; i<len; i++)
        {
            printf("%d",p[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值