ZOJ 3706 Break Standard Weight(暴力思维)

15 篇文章 0 订阅
5 篇文章 0 订阅

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term “scales” for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 1, 4, 5 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input

There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ x, y ≤ 100

Output

For each test case, output the maximum number of possible special masses.

Sample Input

2
4 9
10 10
Sample Output

13
9

本题的大致题意:
每组样例给出一个x和一个y。x和y你只能分开其中一个,分为另外的两个堆,然后用着三堆可以测量更多的数量。为怎样分可以使能测量的数量最多。
下面是AC代码:
本题我是直接暴力做的,做法是使用三个中的一个,两个,或者三个,然后最多可以组成多少种情况。具体做法看AC代码。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;

int b[205];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        int flagmax=0,summax=0;
        memset(b,0,sizeof(b));
        for(int i=1; i<=(x/2); i++)
        {
            summax=0;
            b[i]++;
            b[y]++;
            b[x-i]++;
            b[i+y]++;
            b[abs(i-y)]++;
            b[abs(i+(x-i))]++;
            b[abs(i-(x-i))]++;
            b[abs(y+(x-i))]++;
            b[abs(y-(x-i))]++;
            b[abs(i+(x-i)+y)]++;
            b[abs(i-(x-i)+y)]++;
            b[abs(i-(x-i)-y)]++;
            b[abs(i+(x-i)-y)]++;
            b[abs(-i+(x-i)+y)]++;
            b[abs(-i-(x-i)+y)]++;
            b[abs(-i-(x-i)-y)]++;
            b[abs(-i+(x-i)-y)]++;
            for(int i=1; i<=x+y; i++)
            {
                if(b[i]!=0)
                {
                    summax++;
                }
            }
            memset(b,0,sizeof(b));
            if(summax>flagmax)
            {
                flagmax=summax;
            }
        }
        memset(b,0,sizeof(b));
        for(int i=1; i<=(y/2); i++)
        {
            summax=0;
            b[i]++;
            b[x]++;
            b[y-i]++;
            b[i+x]++;
            b[abs(i-x)]++;
            b[abs(i+(y-i))]++;
            b[abs(i-(y-i))]++;
            b[abs(x+(y-i))]++;
            b[abs(x-(y-i))]++;
            b[abs(i+(y-i)+x)]++;
            b[abs(i-(y-i)+x)]++;
            b[abs(i-(y-i)-x)]++;
            b[abs(i+(y-i)-x)]++;
            b[abs(-i+(y-i)+x)]++;
            b[abs(-i-(y-i)+x)]++;
            b[abs(-i-(y-i)-x)]++;
            b[abs(-i+(y-i)-x)]++;
            for(int i=1; i<=x+y; i++)
            {
                if(b[i]!=0)
                {
                    summax++;
                }
            }
            memset(b,0,sizeof(b));
            if(summax>flagmax)
            {
                flagmax=summax;
            }
        }
         printf("%d\n",flagmax);
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值