HDU 1856 More is better(并查集路径压缩+剪枝优化+暴力枚举)

23 篇文章 0 订阅
15 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1856
More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 23033 Accepted Submission(s): 8349

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output
4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题目大意:题目的意思是让你从所有人中找出最大子集,子集的要求是集合中的人必须直接认识或者间接认识。

算法构思:首先开的数组要足够大,本题的重点我是这样想的:暴力枚举,但是怎么枚举才是最优的呢?首先要找到每个集合中的祖先,可以利用并查集来实现,即某个元素的祖宗是他自己的时候,他一定是某个集合的祖先,然后从第一个人开始枚举就好了,但是要枚举到第多少个人呢?这块又是一个优化,为啥呢,就是在你输入数据的时候,记录下来你所输入的数据中最大的那个是多少。然后再暴力枚举,不断更新最大值就好了。

下面是AC代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int pre[10000005];
int fin(int x)
{
    if(pre[x]==x)
    {
        return x;
    }
    else
    {
        return pre[x]=fin(pre[x]);
    }
}

void join(int x,int y)
{
    int t1=fin(x);
    int t2=fin(y);
    if(t1!=t2)
    {
        pre[t1]=t2;
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)//特判,被坑在这了
        {
            printf("1\n");
            continue;
        }
        int maxn=0,a,b;
        for(int i=0;i<=10000004;i++)
        {
            pre[i]=i;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            join(a,b);
            if(max(a,b)>maxn)//优化技巧
            {
                maxn=max(a,b);
            }
        }
        int sum=0,sum1=0;
        for(int i=1;i<=maxn;i++)
        {
            sum1=0;
            if(pre[i]==i)
            for(int j=1;j<=maxn;j++)
            {
                if(i==fin(j))
                {
                    sum1++;
                }
            }
            sum=max(sum,sum1);//更细最大值
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值