POJ 3723 Conscription(构造+最小生成树Kruskal)

30 篇文章 1 订阅
22 篇文章 0 订阅

题目链接:http://poj.org/problem?id=3723

Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12324 Accepted: 4329
Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.
Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133
Sample Output

71071
54223
Source

POJ Monthly Contest – 2009.04.05, windy7926778

【中文题意】需要征募女兵N人,男兵M人。每征一个人需要花费10000美元。但是如果已经征募的人中有一些关系亲密的人,那么可以少花一些钱。给出若干男的女之间的1-9999之间的亲密度关系,征募某个人的费用是10000-(已经征募的人中和自己的亲密度的最大值)。要求通过适当的征募顺序使得征募所有人所需费用最小。
【思路分析】抄自小白书:让我们设想一下这样一个无向图:在征募某个人a时,如果使用了a和b之间的关系,那么就连一条a到b的边。假设这个图中存在圈,那么无论以什么顺序征募这个圈上的所有人,都会产生矛盾,因此可以知道这个图是一片森林。反之,如果给了一片森林那么就可以使用对应的关系确定征募的顺序。
因此把人看做定点,关系看做边,这个问题就可以转化为求解无向图中的最大劝森林问题,最大劝森林问题可以通过把所有边权取反之后用最小生成树的算法求解。
【AC代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;

struct edge{int u,v,cost;}es[50005];

bool cmp(const edge&e1,const edge&e2)
{
    return e1.cost<e2.cost;
}

int pre[20005];

int fin(int x)
{
    if(x==pre[x])
    {
        return x;
    }
    else
    {
        return pre[x]=fin(pre[x]);
    }
}

void join(int x,int y)
{
    int t1=fin(x);
    int t2=fin(y);
    if(t1!=t2)
    {
        pre[t1]=t2;
    }
}

void union_init(int n)
{
    for(int i=0;i<=n;i++)
    {
        pre[i]=i;
    }
}

int t,n,m,r;

int Kruskal()
{
    union_init(n+m);
    sort(es+1,es+r+1,cmp);
    int sum=0;
    for(int i=1;i<=r;i++)
    {
        if(fin(es[i].u)!=fin(es[i].v))
        {
            join(es[i].u,es[i].v);
            sum+=es[i].cost;
        }
    }
    return sum;
}

int x[50005],y[50005],d[50005];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&r);
        for(int i=1;i<=r;i++)
        {
            scanf("%d%d%d",&x[i],&y[i],&d[i]);
        }
        for(int i=1;i<=r;i++)
        {
            es[i].u=x[i],es[i].v=y[i]+n,es[i].cost=-d[i];
        }
        printf("%d\n",10000*(n+m)+Kruskal());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值