uva 208/Firetruck

The Center City fire department collaborates with the transportation department to maintain maps
of the city which reflects the current status of the city streets. On any given day, several streets are
closed for repairs or construction. Firefighters need to be able to select routes from the firestations to
fires that do not use closed streets.
Central City is divided into non-overlapping fire districts, each containing a single firestation. When
a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and
gives a list of possible routes from the firestation to the fire. You must write a program that the central
dispatcher can use to generate routes from the district firestations to the fires.
Input
The city has a separate map for each fire district. Streetcorners of each map are identified by positive
integers less than 21, with the firestation always on corner #1. The input file contains several test cases
representing different fires in different districts.
• The first line of a test case consists of a single integer which is the number of the streetcorner
closest to the fire.
• The next several lines consist of pairs of positive integers separated by blanks which are the
adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then
the street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and
7 on that section of the street.)
• The final line of each test case consists of a pair of 0’s.
Output
For each test case, your output must identify the case by number (‘CASE 1:’, ‘CASE 2:’, etc). It must
list each route on a separate line, with the streetcorners written in the order in which they appear on
the route. And it must give the total number routes from firestation to the fire. Include only routes
which do not pass through any streetcorner more than once. (For obvious reasons, the fire
department doesn’t want its trucks driving around in circles.)
Output from separate cases must appear on separate lines.
Sample Input
6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0
Sample Output
CASE 1:
1 2 3 4 6
1 2 3 5 6
1 2 4 3 5 6
1 2 4 6
1 3 2 4 6
1 3 4 6
1 3 5 6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1 3 2 5 7 8 9 6 4
1 3 4
1 5 2 3 4
1 5 7 8 9 6 4
1 6 4
1 6 9 8 7 5 2 3 4

1 8 7 5 2 3 4

1 8 9 6 4
There are 8 routes from the firestation to streetcorner 4.


题意:输入一个n<=20的无向图以及k,求按字典序从小到大输出1到k的所以路径,节点不能重复。

先用folyd把能到达k点的节点求出,后面dfs时就会省很多时间。

代码:

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int g[25][25],y[25][25],vis[25],p[25],e,n,s,j;
void floyd()
{
    for(int k=1; k<=n; k++)
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                g[i][j]=(g[i][j]||(g[i][k]&&g[k][j]));
}
void print(int x)
{
    if(x==1) cout<<x;
    else
    {
        print(p[x]);
        cout<<" "<<x;
    }
    //if(x==e) cout<<endl
}
void dfs(int x)
{
    vis[x]=1;
    if(x==e)
    {
        s+=1;
        print(e);
        vis[x]=0;
        cout<<endl;
        return ;
    }
    for(int i=1; i<=n; i++)
    {
        if(i!=x&&y[x][i]&&g[i][e]&&!vis[i])
        {
            //cout<<i<<" "<<g[x][i]<<endl;;
            p[i]=x;
            dfs(i);
        }
    }
    vis[x]=0;
    return;
}
int main()
{
    int t=1;
    while(scanf("%d",&e)!=EOF)
    {
        memset(p,0,sizeof(p));
        memset(g,0,sizeof(g));
        memset(y,0,sizeof(y));
        int u,v;
        n=0;
        while(scanf("%d %d",&u,&v)&&(u+v))
        {
            y[u][v]=y[v][u]=1;
            g[u][v]=g[v][u]=1;
            if(n<v) n=v;
            if(n<u) n=u;
        }
        floyd();
        s=0;
        j=1;
        p[1]=0;
        //cout<<g[1][1]<<endl;
        cout<<"CASE "<<t++<<":"<<endl;
        if(!g[1][e])
            cout<<"There are "<<s<<" routes from the firestation to streetcorner "<<e<<"."<<endl;
        else
        {
            dfs(1);
            cout<<"There are "<<s<<" routes from the firestation to streetcorner "<<e<<"."<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值