hrbust2291


Help C5
Time Limit: 1000 MSMemory Limit: 65535 K
Total Submit: 172(40 users)Total Accepted: 52(38 users)Rating: Special Judge: No
Description
Hello, I’m Sea5, and you can call me C5 instead. I want a program which can sign my name automatically. And my brothers, C0, C1, C2, C3, C4, C6, C7, C8, each of them wants one as well. Can you help us?
Input

First line is the number of test cases T(T<=8).

T lines follow, each line includes an integer N(N<=7), and you should help C(N) to sign his name.

Output

C0’s signature is ‘C’.

When you draw C(N)’s name, you should print the name using C(N-1)’s name as its element, and using the following format to draw it.

*XX

X**

*XX

(X is the element, * is blank space)

And please don’t print extra spaces at the end of line.

For example, C1’s name should be

*CC                    *CC

C                      C**

*CC     But not    *CC

(I use * to show you where are spaces.)

Sample Input
3
0
1
2
Sample Output

C
 CC
C
 CC
    CC CC
   C  C
    CC CC
 CC
C
 CC
    CC CC
   C  C
    CC CC

代码:

#include<iostream>
#include<string.h>
#include<map>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
using namespace std;
char a[3000][3000];
void dfs(int n,int x,int y)
{
    if(n==1)
    {
        a[x][y]='C';
        return ;
    }
    else
    {
        int size=pow(3,n-2);
        dfs(n-1,x,y+size);
        dfs(n-1,x,y+size+size);
        dfs(n-1,x+size,y);
        dfs(n-1,x+size+size,y+size);
        dfs(n-1,x+size+size,y+size+size);
    }
}
int main()
{
    int t,q;
    cin>>t;
    while(t--)
    {
        cin>>q;
        int size=pow(3,q);
        for(int i=1;i<=size;i++)
        {
            for(int j=1;j<=size;j++)
            {
                a[i][j]=' ';
            }
        }
        dfs(q+1,1,1);
        for(int i=1;i<=size;i++)
        {
            for(int j=size;j>=1;j--)
            {
                if(a[i][j]=='C')
                {
                    a[i][j+1]='\0';
                    break;
                }
            }
        }
        for(int i=1;i<=size;i++)
        {
            printf("%s\n",a[i]+1);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值