HDU1075字典树初体验和map写法

其实本不想学关于字符串方面的(我对小细节处理不太好)。但是没有队友,又在某场CF遇到了,就学一下,

字典树基本知识看这个:字典树基础知识

这里通过这道例题HDU1075:神奇的传送门,与大家分享一下。


What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 20504    Accepted Submission(s): 6786


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 


Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 


Output
In this problem, you have to output the translation of the history book.
 


Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 


Sample Output
  
  
hello, i'm from mars. i like earth!



题意: 给你单词和单词的加密写法,给你一段话,翻译出来即可,如果给出的单词不存在对应的单词,按给出的输出即可。

题解:

首先用map来一发,单词的映射关系,正好就是容器map的使用,但是,有很多小地方需要注意,在代码中详细给出。

#include<iostream>
#include<cstdio>
#include<map>
#include<string>
#include<cctype>
using namespace std;
map<string,string >mp;
int main()
{
    string key,value,start;
    char str[3010];
    char op;
    cin>>start;
    while((cin>>value)&&value!="END")
    {
        cin>>key;
        mp[key]=value;//建立起对应关系。
    }
    cin>>start;
    getchar();
    while(1)
    {
        key="";
        while(scanf("%c",&op)!=EOF)
        {
            if(op=='\n'&&key=="END")
                return 0;
            if(op=='\n')
                break;
            if(!isalpha(op))//isalpha函数是判断op是否为英文字母,是1否0.
            {//当不是英文字母时,判断前面的是否存在一个映射。
                if(mp.find(key)!=mp.end())
                    cout<<mp[key];
                    else
                        cout<<key;
                    cout<<op;
                        key="";
            }
                else
                    key+=op;
        }
        cout<<endl;
    }
    return 0;
}

字典树解法:

把加密后的单词加入到字典树里,在每个单词的结尾打标记并记录这个单词在之前出现的下标,

输出跟上面的类似。

代码:

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#define maxn 28
using namespace std;
char s[1000000][15];
char t[4000],f[20],b[4000];
typedef struct dot
{
    bool flag;
    dot *next[maxn];
    int v;
} T;
dot root;
dot *newNode()
{
    dot *temp=new dot;
    temp->v=-1;
    temp->flag=false;
    for(int i=0; i<maxn; i++)
        temp->next[i]=NULL;
    return temp;
}
void Insert(char *st,int tmp)
{
    int len=strlen(st);
    int id=0;
    dot *p=&root;
    for(int i=0; i<len; i++)
    {
        id=st[i]-'a';
        if(p->next[id]==NULL)
            p->next[id]=newNode();
        p=p->next[id];
    }
    p->flag=true;
    p->v=tmp;
}
int Search(char *st)
{
    int len=strlen(st);
    int id=0;
    dot *p=&root;
    for(int i=0; i<len; ++i)
    {
        id=st[i]-'a';
        p=p->next[id];
        if(p==NULL)
            return 0;
    }
    if(p->flag)
        return p->v;
    else
        return 0;
}
int main()
{
    int j=1;
    scanf("%s",s[j]);
    while(1)
    {
        scanf("%s",s[j]);
        if(s[j][0]=='E')
            break;
        j++;
        scanf("%s",s[j]);
        Insert(s[j],j);
        j++;
    }
    getchar();
    gets(b);
    while(1)
    {
        gets(t);
        if(t[0]=='E')
            break;
        int len=strlen(t);
        j=0;
        for(int i=0; i<len; i++)
        {
            if(isalpha(t[i]))
                f[j++]=t[i];
            else
            {
                f[j]='\0';
                if(Search(f))
                {
                    int num=Search(f);
                    printf("%s",s[num-1]);
                }
                else
                {
                    printf("%s",f);
                }
                printf("%c",t[i]);
                memset(f,0,sizeof(f));
                j=0;
            }
        }
        printf("\n");
    }

}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值