LightOJ 1035 Intelligent Factorial Factorization [预处理+一半的 质因子分解]【数论】

题目链接:LightOJ 1035 Intelligent Factorial Factorization


Intelligent Factorial Factorization
Time Limit:500MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Given an integer N, you have to prime factorize N! (factorial N).

Input
Input starts with an integer T (≤ 125), denoting the number of test cases.

Each case contains an integer N (2 ≤ N ≤ 100).

Output
For each case, print the case number and the factorization of the factorial in the following format as given in samples.

Case x: N = p1 (power of p1) * p2 (power of p2) * …

Here x is the case number, p1, p2 … are primes in ascending order.

Sample Input
3
2
3
6
Sample Output
Case 1: 2 = 2 (1)
Case 2: 3 = 2 (1) * 3 (1)
Case 3: 6 = 2 (4) * 3 (2) * 5 (1)


题目大意 就是把N! 质因子分解一下

题解: 因为数据量很小 所以预处理一下所有N! 的质因子个数即可

这种办法 应该可以做到n<=1000
n<10000的时候用容器存一下 而且时间在大一丢丢 应该还是能做的

因为数据量太小 所有算法都是最最最最最暴力的

附本题代码

—————————-

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <map>
#include <vector>
#include <set>

using namespace std;

#define LL unsigned long long int

int Is_or[500];
void Prime()
{
    int n=200;
    int k=0;
    memset(Is_or,1,sizeof(Is_or));
    Is_or[0]=Is_or[1]=0;
    for(int i=2; i<n; i++)
    {
        if(Is_or[i])
        {
            for(int j=i+i; j<n; j+=i)
            {
                Is_or[j]=0;
            }
        }
    }
    return ;
}

int has[105][105];

void init()
{
    int num;
    memset(has,0,sizeof(has));
    for(int i=2;i<=100;i++)
    {
        for(int j=2;j<=i;j++)
        {
            num=i;
            if(num%j==0&&Is_or[j])
                while(num%j==0)
                    has[i][j]++,num/=j;
        }
    }

    for(int i=1;i<=100;i++)
    {
        for(int j=1;j<=100;j++)
        {
            has[i][j]+=has[i-1][j];
        }
    }

    return ;
}

int main()
{
    Prime();
    init();
    int t,tt=0,num;
    LL p,l;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d",&n);
        printf("Case %d: %d = ",++tt,n);

        printf("%d (%d)",2,has[n][2]);
        for(int i=3;i<=n;i++)
        {
            if(has[n][i])
            printf(" * %d (%d)",i,has[n][i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要求出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先筛选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值