HDU 2838 Cow Sorting [树状数组]【数据结构】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2838
—————————————————-.
Cow Sorting

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3275 Accepted Submission(s): 1102

Problem Description
Sherlock’s N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique “grumpiness” level in the range 1…100,000. Since grumpy cows are more likely to damage Sherlock’s milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.

Sample Input
3
2
3
1

Sample Output
7

Hint

Input Details

Three cows are standing in line with respective grumpiness levels 2, 3, and 1.
Output Details

2 3 1 : Initial order.
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4).
1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).

Source
2009 Multi-University Training Contest 3 - Host by WHU

—————————————————-.

题目大意:
主要看hint就能知道了
其实还是一个冒泡排序 只不过求得是总花费 每次花费为交换的两个值得和

解题思路:
首先用树状数组对每个数求一下他出现之前逆序对数
对于每个数来说 它对结果的贡献就是
他之前的逆序对数*a_i+与他逆序的数的总和

这里直接采取了维护两个树状数组的暴力思路:
一个维护逆序对个数
一个维护逆序数的和

注意要用I64 否则溢出了…

附本题代码
————————————————————————.

#include <bits/stdc++.h>

#define abs(x)          (((x)>0)?(x):-(x))
#define lalal           puts("*********")
#define Rep(a,b,c)      for(int a=(b);a<=(c);a++)
#define Req(a,b,c)      for(int a=(b);a>=(c);a--)
#define Rop(a,b,c)      for(int a=(b);a<(c);a++)
#define s1(a)           scanf("%d",&a)
typedef long long int LL;
using namespace std;
/**************************************/

const int N = 100000+5;
#define lowbit(x)    (x&-x)
LL sum1[N],sum2[N];
int cnt;
void update1(int index,int val){
    for(int i=index;i<=cnt;i+=lowbit(i))
        sum1[i]+=val;
    return ;
}
LL getSum1(int index){
    LL ans=0;
    for(int i=index;i>0;i-=lowbit(i))
        ans+=sum1[i];
    return ans;
}
void update2(int index,int val){
    for(int i=index;i<=cnt;i+=lowbit(i))
        sum2[i]+=val;
    return ;
}
LL getSum2(int index){
    LL ans=0;
    for(int i=index;i>0;i-=lowbit(i))
        ans+=sum2[i];
    return ans;
}

int main(){
    while(~s1(cnt)){
        int x;
        LL ans=0;
        memset(sum1,0,sizeof(sum1));
        memset(sum2,0,sizeof(sum2));
        Rep(i,1,cnt){
            s1(x);
            ans+=x*(getSum2(cnt)-getSum2(x))+(getSum1(cnt)-getSum1(x));
            update1(x,x);
            update2(x,1);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值