1003. Emergency (25) <优先队列>

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
简单就是说,有n个点,m个边,最后输出到达终点的最短路径的个数,并且求出最短路径中各点各点权值的最大值
这题跟九度 最短路径问题 基本一样,就是多一个输出路径个数

直接用Dijkstra,用ci纪录到达每个点有多少种方案
如果len[i]需要更新,那么le也需要跟着更新,求最大值
主要就是次数

假如0-1长度为1,0-2长度为2,1-2长度为1
从0开始,先搜索1,len1更新然后1的方案就被0代替
然后搜索2,len2更新,2的到达方案也被0代替
然后从1开始
搜索2,这时候len2不需要更新,但是len2=len1+map12,
所以2的到达方案等于本身+1的到达方案,后面同理
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
const int INF=1<<28;
typedef pair<int,int> P; 
int n,m,c2,c1;
int value[500+5];
int map[500+5][500+5];
int ci[600],len[600],v[600]={0},le[600];//le纪录最短路径中各点的最大和 
//ci代表到达一个点的种数 
void Dijkstra(int x){
	for(int i=0;i<n;i++) len[i]=INF,le[i]=0;
	ci[x]=1;
	le[x]=value[x];
	len[x]=0;
	priority_queue<P,vector<P>,greater<P> >que; 
	que.push({len[x],x});
	while(que.size()){
		P p=que.top();
		que.pop();
		int num=p.second;
		if(v[num])  continue;
		//if(num!=c2)
		v[num]=1;
		for(int i=0;i<n;i++){
			if(map[num][i]!=INF&&len[i]>=len[num]+map[num][i]){ 
			if(len[i]>len[num]+map[num][i]) {//更新长度值,并相应的le跟着更新 
				le[i]=le[num]+value[i];
				len[i]=len[num]+map[num][i];	
				ci[i]=ci[num];
			}
			else if(len[i]==len[num]+map[num][i]){
				if(le[i]<le[num]+value[i]) 
                 le[i]=le[num]+value[i];
				ci[i]+=ci[num];
			}
			que.push({len[i],i});			
			}
		}
	}
}
int main(){
    cin>>n>>m>>c1>>c2;
    for(int i=0;i<n;i++){
    	cin>>value[i];
	}
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++) map[i][j]=INF;
	}
	for(int i=0;i<m;i++){
		int a,b,c;
		cin>>a>>b>>c;
		map[a][b]=map[b][a]=c;
	}
	Dijkstra(c1);
	cout<<ci[c2]<<" "<<le[c2];
	return 0;
}
/*
5 6 0 4
1 2 1 5 3 
0 1 1
0 2 2
0 3 1
1 2 1
3 4 2
2 4 1
*/





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值