1103. Integer Factorization (30)

13 篇文章 0 订阅
8 篇文章 0 订阅

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112+ 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible

将一个数分成k个num^p之和

并且输出num的和最大的,如果出现相同情况

例如 8=7^1+1^1 和 8=4^1+4^1

应该用输出第一个,每个下标的数都比较,取最大的

这点要注意一下,一个大的得分点


我思路是直接找到最大的数,从这个数开始遍历到1,然后回溯

for(i=1;;i++){
if(pow(i,p)>=n) break;
}

找到最大的i,从i->1开始遍历

回溯的过程注意剪枝,小心超时

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<stack>
using namespace std;
int a[500];
int n,k,p;
int out[500];
int maxn=0;
bool cmp(int a,int b){
	return a>b;
}
void f(int x,int len,int sum){
	a[len]=x;
	if(len>k||sum>n) return ;
	if(len==k&&sum==n){
		int fz=0;
		int f[500];
		for(int i=0;i<len;i++) fz+=a[i];
	//	sort(f,f+len,cmp);
		if(fz>maxn){
			maxn=fz;
			for(int i=0;i<len;i++) out[i]=a[i];
		}
		if(fz==maxn){
			maxn=fz;
			int flag=0;
			for(int i=0;i<len;i++){
				if(a[i]>out[i]){
					flag=1;
					break;
				}else if(a[i]==out[i]){
					continue;
				}
				else break;
			}
			if(flag) 
			for(int i=0;i<len;i++) out[i]=a[i];
		}
	}
	else{
		for(int i=x;i>=1;i--){
			f(i,len+1,sum+pow(x,p));
		}
	}
}
int main(){
	cin>>n>>k>>p;
	int i;
	for(i=1;;i++){
		if(pow(i,p)>=n) break;
	}
	for(;i>=1;i--)
	f(i,0,0);
	if(maxn==0) cout<<"Impossible";
	else {
		printf("%d = %d^%d",n,out[0],p);
		for(i=1;i<k;i++){
			printf(" + %d^%d",out[i],p);
		} 
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值