*1115. Counting Nodes in a BST (30) <二叉搜索树>

12 篇文章 0 订阅
9 篇文章 0 订阅

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6
新题。。之前建立BST树是给定的树,现在是自己建立,没遇到过

建立树是看别人的博客

最后遍历树,找出来最后两层结点的个数

我用的是广搜,pair存两个遍历,一个是结点,一个是层数


#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<stack>
using namespace std;
typedef struct tree{
	int num;
	struct tree *left,*right;
}tree,*linktree;
typedef pair<linktree,int> P;
int k; 
linktree creat(linktree head,int num){
	if(head==NULL){
		head=new tree();
		head->num=num; 
		head->left=NULL;
		head->right=NULL;
	}
	else if(num<=head->num){
		head->left=creat(head->left,num);
	}
	else if(num>head->num){
		head->right=creat(head->right,num);
	}
	return head;
}
int main(){
	cin>>k;
	linktree head=NULL; 
	for(int i=0;i<k;i++){
		int num;
		cin>>num;
		head=creat(head,num);
	} 
	queue<P> que;
	que.push({head,0});
	int a[10000]={0};
	int maxn=0;
	while(que.size()){
		P p=que.front();
		que.pop();
		linktree t=p.first;
		int len=p.second;
		a[len]++;
		if(len>maxn) maxn=len;
		if(t->left!=NULL) que.push({t->left,len+1}); 
		if(t->right!=NULL) que.push({t->right,len+1}); 
	}
    printf("%d + %d = %d",a[maxn],a[maxn-1],a[maxn]+a[maxn-1]); 
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值