1110. Complete Binary Tree (25) <完全二叉树>

12 篇文章 0 订阅
9 篇文章 0 订阅

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1

判断是否为完全二叉树
注意输入的结点不一定是个位数。。我直接a-‘0’来做。错了一大堆
可以直接用sscanf(a,"%d",sum) 将字符串格式化为整形赋值给sum
如果出现空的结点,判断是否已经遍历完树,遍历结束就是YES,反之为NO
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<stack>
using namespace std;
typedef struct tree{
	int num,left,right;
}tree;
tree t[1000];
int n;
int father[1000]; 
int cnt=1;
int endx=0,start;
int find(int x){
	if(x==father[x]) return x;
	return father[x]=find(father[x]);
}
void cengxu(int x){
	queue<int> que;
	que.push(x);
	endx=x;
	while(que.size()){
		int num=que.front();
		que.pop();
		if(t[num].left!=-1){
			que.push(t[num].left);
			endx=t[num].left;
			cnt++;
		} 
		else{
			if(cnt==n) cout<<"YES "<<endx; 
	        else cout<<"NO "<<start;
	        return; 
		} 
		if(t[num].right!=-1){
			que.push(t[num].right);
			endx=t[num].right;
			cnt++;
		}
		else{
			if(cnt==n) cout<<"YES "<<endx; 
	        else cout<<"NO "<<start;
	        return; 
		} 
		//if(t[num].left==-1||t[num].right==-1){
			
		//} 
	}
}
int main(){
	cin>>n;
	for(int i=0;i<1000;i++) father[i]=i;
	
	for(int i=0;i<n;i++){
		char a[4],b[4]; 
		scanf("%s %s",a,b); 
		if(a[0]!='-'){
			int sum=0;
			for(int i=0;i<strlen(a);i++) sum=sum*10+a[i]-'0';
			father[sum]=i;
			t[i].left=sum;
		}
		else t[i].left=-1;
		
		if(b[0]!='-'){
			int sum=0;
			for(int i=0;i<strlen(b);i++) sum=sum*10+b[i]-'0';
			father[sum]=i;
			t[i].right=sum;
		}
		else t[i].right=-1;
	}
	start=find(0);
	cengxu(start);
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值