(卡特兰数变形m+n,找零)Buy the Ticket--HDOJ

Buy the Ticket

Problem Description
The \\\\”Harry Potter and the Goblet of Fire\\\\” will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won\\\\’t be stopped from the first person till the last person.
Note: initially the ticket-office has no money.

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.

Input
The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.

Output

        For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.

Sample Input
3 0
3 1
3 3
0 0

Sample Output
Test #1:
6
Test #2:
18
Test #3:
180

Author
HUANG, Ninghai

Recommend
Eddy

总结:
以前的卡特兰数的题目,都是两个N人的队伍进行一些操作,而这次两队人数不同。
卡特兰数公式
C(2N,N)/(N+1) = C (2N,N) - C (2N,N+1) ①

这道题中,如果100的人数n 大于50 的人数m,直接输出0就可以
接下来就是针对 m>n的情况了
我们知道①式中有两个N,即N+N,而我们题目给的是M+N
毋庸置疑,2N就是M+N,而N+1就是M+1
即C (M+N,N) - C (M+N,M+1) (网上有很多关于这个式子的解释)
总数 减去 不满足要求的数目
因为每个人都是不同的,所以还要乘上M!*N!
最后的结果就是
(C (M+N,N) - C (M+N,M+1)) * M!*N!
化简后为
(M+N)!*(M-N+1)/(M+1)

import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class Main
{
    public static void main(String[] args)
    {
        Scanner cin = new Scanner(System.in);
        int cnt=1;
        while(cin.hasNext())
        {
            int m,n;
            m = cin.nextInt();
            n = cin.nextInt();
            if((0==n && 0==m)) break;
            if(n > m)
            {
                System.out.println("Test #"+cnt+":");
                cnt++;
                System.out.println(0);
                continue;
            }
            BigInteger ans = BigInteger.valueOf(1);
            BigInteger f2 = BigInteger.valueOf(1);
            for(int i=1; i<=m+n; ++i)
            {
                ans = ans.multiply(BigInteger.valueOf(i));
            }
            ans = ans.multiply(BigInteger.valueOf(m-n+1)).divide(BigInteger.valueOf(m+1)); 

            System.out.println("Test #"+cnt+":");
            cnt++;
            System.out.println(ans);
        }
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值