HDU-1133Buy the Ticket

Problem Description
The \\\\\\\"Harry Potter and the Goblet of Fire\\\\\\\" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won\\\\\\\'t be stopped from the first person till the last person. 
Note: initially the ticket-office has no money. 

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.
 
Input
The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.
 
Output

            For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.
 
Sample Input
3 0
3 1
3 3
0 0
 
Sample Output
Test #1:
6
Test #2:
18
Test #3:
180

由于确定买票序列后,持同等面额的人交换位置不会影响结果,因此可以先将持同等面额的人看做全部相同

即将m个持50元的人和n个持100元的人看做相同,等确定m+n有多少种可能的排列次序后,乘以A(n,n)和A(m,m)

考虑m个持50元的人和n个持100元的人组成的排列,排在最尾的一人为P,假设P持有的为50元,则前面(m+n-1)个人中,有m-1持50元,n人持100元;同理,如果P持有的为100元,则前面有m人持50元,n-1人持100元。

则P参与排队的情况数 由 P持有的面额和P之前所有人排队的情况数决定,即:Situation(m,n) = Situation(m-1,n) + Situation(m,n-1)

打表计算即可。

此外,本题计算全排列,需要用到大数阶乘。

import java.util.*;
import java.math.*;
public class Main {
    public static void main(String[] args){
        Scanner input=new Scanner(System.in);
        BigInteger a=new BigInteger("1");
        BigInteger c=new BigInteger("0");
        BigInteger ans[][]=new BigInteger[105][105];
        for(int i=0;i<=100;i++)
            for(int j=0;j<=100;j++){
                if(i<j) ans[i][j]=c;
                else if(j==0) ans[i][j]=a;
                else{
                    ans[i][j]=ans[i][j-1].add(ans[i-1][j]);
                }
            }
        int count=0;
        while(true){
            int m=input.nextInt(),n=input.nextInt();
            if(m==0 && n==0) break;
            BigInteger e=new BigInteger("1");
            BigInteger f=new BigInteger("0");
            for(int i=1;i<=m;i++){
                f=f.add(a);
                e=e.multiply(f);
            }
            BigInteger g=new BigInteger("1");
            BigInteger h=new BigInteger("0");
            for(int i=1;i<=n;i++){
                h=h.add(a);
                g=g.multiply(h);
            }
            BigInteger b=ans[m][n].multiply(e).multiply(g);
            System.out.println("Test #"+ ++count+":");
            System.out.println(b);
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值