(DP,多重背包) Coins --HDOJ

Coins
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 878 Accepted Submission(s): 357

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output
For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source
2009 Multi-University Training Contest 3 - Host by WHU

Recommend
gaojie

总结;
多重背包问题,因为每种物品的数量不确定,当一种物品的数量很大时,可以看成完全背包问题;当一种物品数量较少时,可以看成是01背包问题

至于while(k < num[i]) 这个地方,不太理解,据说是用了二分思想来做的,我想了一下:假设目前我们的k是4,我们要求的是能装下的最大价值,将4个物品看成一个往背包里面放,既然能放得开,为什么还要一个一个的去放,直接将4个物品一下子放进去不就行了。这样效率就比较高了

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int coin[200];
int dp[100005];
int num[200];
int main(void)
{
 //   freopen("in.txt","r",stdin);
    int n,W;
    while(scanf("%d %d",&n,&W))
    {
        if(!n && !W) break;

        memset(dp,0,sizeof(dp));

        for(int i=0; i<n; ++i)
            scanf("%d",&coin[i]);
        for(int i=0; i<n; ++i)
            scanf("%d",&num[i]);

        dp[0] = 0;
        long long ans=0;
        for(int i=0; i<n; ++i)
        {

            if(num[i]*coin[i] > W)
            {
                for(int j=coin[i]; j<=W; ++j)
                    dp[j] = max(dp[j],dp[j-coin[i]]+coin[i]);
                continue;
            }
            int k=1;
            while(k <num[i])
            {
                for(int j=W; j>=k*coin[i]; --j)
                    dp[j] = max(dp[j],dp[j-coin[i]*k]+coin[i]*k);
                num[i] -= k;
                k *=2;
            }
            for(int j=W; j>=num[i]*coin[i]; --j)
                    dp[j] = max(dp[j],dp[j-coin[i]*num[i]]+coin[i]*num[i]);

        }
        for(int i=1; i<=W; ++i)
            if(dp[i] == i) ans++;
        cout << ans <<endl;
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值