USACO hamming

考试周终于过去了一半,可以继续写USACO了。

先来看一下题目吧。

Hamming Codes
Rob Kolstad

Given N, B, and D: Find a set of N codewords (1 <= N <= 64), each of length B bits (1 <= B <= 8), such that each of the codewords is at least Hamming distance of D (1 <= D <= 7) away from each of the other codewords. The Hamming distance between a pair of codewords is the number of binary bits that differ in their binary notation. Consider the two codewords 0x554 and 0x234 and their differences (0x554 means the hexadecimal number with hex digits 5, 5, and 4):

        0x554 = 0101 0101 0100
        0x234 = 0010 0011 0100
Bit differences: xxx  xx

Since five bits were different, the Hamming distance is 5.

PROGRAM NAME: hamming

INPUT FORMAT

N, B, D on a single line

SAMPLE INPUT (file hamming.in)

16 7 3

OUTPUT FORMAT

N codewords, sorted, in decimal, ten per line. In the case of multiple solutions, your program should output the solution which, if interpreted as a base 2^B integer, would have the least value.

SAMPLE OUTPUT (file hamming.out)

0 7 25 30 42 45 51 52 75 76
82 85 97 102 120 127

 这条题目不难,由于数据量很小,因此使用的方法是直接遍历。

/**
ID: njuwz151
TASK: hamming
LANG: C++
*/
#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 9;

int count(int a, int b);

int main() {
    freopen("hamming.in", "r", stdin);
    freopen("hamming.out", "w", stdout);
    
    int n, b, d;
    cin >> n >> b >> d;
    
    int result[1 << maxn];
    result[0] = 0;
    int n_ptr = 1;
    for(int i = 1; i < (1 << b); i++) {
        if(n_ptr > n) {
            break;
        }
        bool can_add = true;
        for(int j = 0; j < n_ptr; j++) {
            if(count(i, result[j]) < d) {
                can_add = false;
                break;
            }
        }
        if(can_add) {
            result[n_ptr] = i;
            n_ptr++; 
        }
    }
    for(int i = 0; i < n - 1; i++) {
        cout << result[i];
        if((i + 1) % 10) {
            cout << " ";
        } else {
            cout << endl;
        }
    }
    cout << result[n - 1] << endl;
} 

int count(int a, int b) {
    int result = 0;
    for(int i = 0; i < maxn; i++) {
        if(((a>>i) & 1) != ((b>>i) & 1)) {
            result++;
        }
    }
    return result;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值