NEFU 2016省赛演练一 I题 (模拟题)

这题没名字

Problem:I
Time Limit:2000ms
Memory Limit:65535K

Description

Now give you an interger m and a sequence: s[1], s[2], ...... , s[N] in not decreasing order. The length of the sequence is n. Your task is to find out how many pair of a and b satisfy a+b=m. Note that each element of the sequence can use once at most. 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N(0<n<=1000000), M(0<m<=1000000000), which denote the length of the sequence and the sum of a+b, respectively. The next line give n interger(0<s[i]<=10000000)。 Note the input is huge.

Output

For each case, output the num of pairs in one line.

Sample Input

3 3
1 1 2
3 2
1 1 1
5 5
1 1 2 3 4

Sample Output

1
1
2

题意:给定n和m,输入n个数,判断在这些数中有多少组两个数的和为m。
题解:用while跑是最快的,跑n存在风险,跑数组可能超时,跑m一定超时。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
typedef long long ll;
ll a[1000005];
int main()
{
    ll i,n,m,data;
    while(scanf("%lld%lld",&n,&m)!=EOF)
    {
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
        scanf("%lld",&a[i]);
        ll ans=0;
        sort(a,a+n);
        ll l=0,r=n-1;
        while(l<r)
        {
            if(a[l]+a[r]>m)
            r--;
            else if(a[l]+a[r]<m)
            l++;
            else
            {
                ans++;
                r--;
                l++;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值