UVA-1587 Box

UVA-1587 Box

题目大意:给出六个长方形的长和宽,判断能否构成长方体

Sample Input

1345 2584
2584 683
2584 1345
683 1345
683 1345
2584 683
1234 4567
1234 4567
4567 4321
4322 4567
4321 1234
4321 1234

Sample Output

POSSIBLE
IMPOSSIBLE

解题思路:先排序,再判断

#include <iostream>
#include <algorithm>
using namespace std;

struct s {
        int w;
        int h;
};
bool cmp(s a,s b) {
        if (a.w < b.w)
            return true;
        if (a.w == b.w && a.h < b.h)
            return true;
        return false;
}
int main() {
    s a[10];
    while (scanf("%d%d", &a[0].w, &a[0].h) != EOF) {
        for (int i = 1; i < 6; i++) {
            scanf("%d%d", &a[i].w, &a[i].h);
        }                                          //输入


        for (int i = 0; i < 6; i++) {
            if (a[i].w > a[i].h)
                swap(a[i].w,a[i].h);
        }
        sort(a, a + 6, cmp);                       //排序


        //方法一
        //bool value = true;
        //for (int i = 0; i < 6; i = i + 2) {
        //  if (a[i].w != a[i + 1].w  || a[i].h != a[i + 1].h) {
        //      value = false;
        //      break;
        //  }
        //}
        //if (value)
        //  if (a[0].w == a[2].w && a[0].h == a[4].w && a[2].h == a[4].h)
        //      value = true;
        //  else 
        //      value = false;

        //方法二
        //bool value = false;
        //if (((a[0].w == a[1].w && a[1].w == a[2].w && a[2].w == a[3].w) && (a[0].h == a[1].h && a[1].h == a[4].w && a[4].w == a[5].w)) && (a[2].h == a[3].h && a[3].h == a[4].h && a[4].h == a[5].h))
        //  value = true;

        if (value)
            cout << "POSSIBLE" << endl;
        else
             cout << "IMPOSSIBLE" << endl;


    //将结构体输出出来      
    //  for (int i = 0; i < 6; i++) {
    //      cout << a[i].w << "  " << a[i].h << endl;
    //  }

    }
    return 0;
}

本来想吐槽下,搞了半天都没有过,最后整理代码后才搞出来。  “bool value = true;” 不能放在main函数外面,要放在 main 函数里面。不要问我为什么,我这会儿也不知道

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值