1103 Integer Factorization (30分)

12 篇文章 0 订阅

1 问题

1103 Integer Factorization (30分)
The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:
For each case, if the solution exists, output in the format:

N = n[1]^P + … n[K]^P

where n[i] (i = 1, …, K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12^2 + 4​^2​​ +2^​2 +2​^2 +1​^2, or 11^2 + 6^2+ 2^2 + 2^2 + 2^2, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence { a1,a2,⋯,aK} is said to be larger than { b1,b2,⋯,b​K} if there exists 1≤L≤K such that ai =bi for ibL.
If there is no solution, simple output Impossible.

Sample Input 1:
169 5 2
 
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
    
Sample Input 2:
169 167 3
    
Sample Output 2:
Impossible

2 解析

  • 题意:求出K个P次方的数的总和为N的K数之和最大的序列,并按序列非递增的顺序以及相应的格式输出
  • 思路:
    • 1 使用递归求出序列
      • 参数:序列数index,序列个数nowK,序列和sum,序列次方幂的和sumSqu
      • 递归边界:序列数为0 || 序列个数大于k || 序列次方幂的和大于N
      • 递归式子:
        • 序列数、序列个数+1、 序列和+序列数、序列次方幂和+序列数的次方幂(选择这个数)
        • 序列数-1,序列个数、序列和、序列数的次方幂(不选这个数)
      • 序列个数为K && 序列次方幂的和为N
        • 如果序列和比之前的大,就更新序列和,并重新存序列
      • 2 优化
        • 序列数从N到0开始遍历,让字典序大的优先被选到,可以不用进行sort排序
        • 用一个序列次方幂和专门来存1~N的次方幂

3 参考代码

#include <cstdio>
#include <vector>
#include <cmath>

using std::vector;

const int MAXN = 450;

//169 5 2

int A[MAXN];
int N, K, P;
int maxSum  = -1;
vector<int>temp, ans,fac;

//index号数 已选了nowK个数  总和sum  已选数的每个数的K次方和
void BFS(int index, int nowK, int sum, int sumSqu){
    if(nowK == K && sumSqu == N){
        if(sum > maxSum){
            maxSum = sum;
            ans = temp;
        }
    }

    if(index == 0|| nowK > K || sumSqu > N) return;

    temp.push_back(index);
    BFS(index, nowK + 1, sum + index , sumSqu + fac[index]);

    temp.pop_back();
    BFS(index - 1, nowK, sum, sumSqu);

}

int main(int argc, char const *argv[])
{
    scanf("%d%d%d", &N, &K, &P);//总和N 、K个数、P次方

    int tempPow = 0,k = 1;
    while(tempPow <= N){
        fac.push_back(tempPow);
        tempPow = pow(k++, P);
    }

    BFS(fac.size() - 1, 0, 0, 0);

    if(maxSum != -1){
        printf("%d = ", N);
        for (vector<int>::const_iterator it = ans.begin(); it != ans.end() ; ++it)
        {
            if(it != ans.begin()) printf(" + ");
            printf("%d^%d", *it, P);
        }
    }else{
        printf("Impossible\n");
    }

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值