1020 Tree Traversals (25分)

23 篇文章 0 订阅

1 题目

1020 Tree Traversals (25分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

      
    
Sample Output:
4 1 6 3 5 7 2

2 解析

  • 题意:给出二叉树的后序和中序序列,求二叉数的层数遍历序列
  • 思路:
    • 先由后序和中序建立二叉树
    • 然后借助队列用层序输出二叉树

3 参考代码

#include <cstdio>
#include <queue>

using std::queue;

const int MAXN = 40;
int post[MAXN];
int in[MAXN];

struct node
{
    int data;
    node* lchild;
    node* rchild;
}Node;

node* Create(int postL, int postR, int inL, int inR){//后序、中序建立二叉树
    if(postL > postR){
        return NULL;
    }

    node* root = new node;
    root->data = post[postR];

    int k;
    for (k = inL; k <= inR; ++k)
    {
        if(in[k] == root->data){
            break;
        }
    }

    int numLeft = k - inL;

    root->lchild = Create(postL, postL + numLeft - 1, inL, k - 1);
    root->rchild = Create(postL + numLeft , postR - 1, k + 1, inR);

    return root;
}

void layerorder(node* root){
    queue<node*> q;//队列存地址
    q.push(root);
    while(!q.empty()){
        node* now = q.front();
        q.pop();
        
        printf("%d",now->data);//取出并访问队首元素

        if(now->lchild != NULL){//左子树非空
            q.push(now->lchild);
        }
        if(now->rchild != NULL){//右子树非空
            q.push(now->rchild);
        }

         if(!q.empty()){
            printf(" ");
        }
    }

}

int main(){
    int N;
    scanf("%d", &N);
    
    for (int i = 0; i < N; ++i)
    {
        scanf("%d", &post[i]);
    }

    for (int i = 0; i < N; ++i)
    {
        scanf("%d", &in[i]);
    }

    node* root;
    root = Create(0, N - 1, 0, N - 1);

    layerorder(root);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值