1058 A+B in Hogwarts (20 分)

 

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

参考代码:

#include<cstdio>
long long  Galleon = 17 * 29;
long long  Sickle = 29;
int main(int argc, char const *argv[])
{
	long long  a1, b1, c1;
	long long  a2, b2, c2;
	scanf("%lld.%lld.%lld %lld.%lld.%lld", &a1, &b1, &c1, &a2, &b2, &c2);
	long long  sum = (a1 + a2) * Galleon + (b1 + b2) * Sickle + (c1 + c2);
	printf("%lld.%lld.%lld\n", sum / Galleon, sum % Galleon / Sickle, sum % Sickle);
	return 0;
}

参考代码2:

#include<cstdio>
int main(int argc, char const *argv[])
{
	int a[3],b[3],c[3];
	scanf("%d.%d.%d %d.%d.%d", &a[0], &a[1], &a[2], &b[0], &b[1], &b[2]);
	int carry = 0;
	c[2] = (a[2] + b[2]) % 29;
	carry = (a[2] + b[2]) / 29;
	c[1] =(a[1] + b[1] + carry) % 17;
	carry =(a[1] +b[1] + carry) / 17;
	c[0] =a[0] + b[0] +carry;
	printf("%d.%d.%d\n", c[0], c[1], c[2]);
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值