1077 Kuchiguse (20 分)

The Japanese language is notorious(臭名昭著) for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated(夸张的) artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype(模式化观念) for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix(后缀), write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

参考代码:

//Kuchiguse
#include<cstdio>
#include<cstring>
char str[100][260];
int  minlen = 256;
int num = 0;

int main(int argc, char const *argv[])
{
	int N;
	scanf("%d", &N);
	getchar();

	for (int i = 0; i < N; ++i)
	{
		fgets(str[i], 261, stdin);
		int len = strlen(str[i]) - 1;
		if(len < minlen) minlen = len;
	for (int j = 0; j < len / 2; ++j)
	{
		char temp = str[i][j];
		str[i][j] = str[i][len - j - 1];
		str[i][len - j - 1] = temp;
	}
	}

	for (int i = 0; i < minlen; ++i)
	{
		char temp = str[0][i];
		bool same = true;
		for (int j = 1; j < N; ++j)
		{
			if(temp != str[j][i]){
				same = false;
				break;
			}
		}
		if(same) num++;
		else break;
	}

	if(num == 0){
		printf("nai");
	}else{
		for (int i = num - 1; i >= 0; --i)
		{
			printf("%c", str[0][i]);
		}
	}
	printf("\n");
	return 0;
}

 参考代码2:

#include<cstdio>
#include<cstring>
char str[100][260];
int  minlen = 256;
int num = 0;
int k ;
void reverse(char str[][260]){
	int len = strlen(str[k]) - 1;
		if(len < minlen) minlen = len;
		for (int j = 0; j < len / 2; ++j)
		{
			char temp = str[k][j];
			 str[k][j] = str[k][len - j - 1];
			 str[k][len - j - 1] = temp;  
		}
}

int main(int argc, char const *argv[])
{
	int N;
	scanf("%d", &N);
	getchar();

	for (k = 0; k < N; ++k)
	{
		fgets(str[k], 261, stdin);
		 reverse(str);
	// 	int len = strlen(str[i]) - 1;
	// 	if(len < minlen) minlen = len;
	// for (int j = 0; j < len / 2; ++j)
	// {
	// 	char temp = str[i][j];
	// 	str[i][j] = str[i][len - j - 1];
	// 	str[i][len - j - 1] = temp;
	// }
	}

	for (int i = 0; i < minlen; ++i)
	{
		char temp = str[0][i];
		bool same = true;
		for (int j = 1; j < N; ++j)
		{
			if(temp != str[j][i]){
				same = false;
				break;
			}
		}
		if(same) num++;
		else break;
	}

	if(num == 0){
		printf("nai");
	}else{
		for (int i = num - 1; i >= 0; --i)
		{
			printf("%c", str[0][i]);
		}
	}
	printf("\n");
	return 0;
}

参考代码3:

#include<cstdio>
#include<cstring>
char str[100][260];
int  minlen = 256;
int num = 0;
void reverse(char str[]){
	int len = strlen(str) - 1;
		if(len < minlen) minlen = len;
		for (int j = 0; j < len / 2; ++j)
		{
			char temp = str[j];
			 str[j] = str[len - j - 1];
			 str[len - j - 1] = temp;  
		}
}

int main(int argc, char const *argv[])
{
	int N;
	scanf("%d", &N);
	getchar();

	for (int i = 0; i < N; ++i)
	{
		fgets(str[i], 261, stdin);
		 reverse(str[i]);
	}

	for (int i = 0; i < minlen; ++i)
	{
		char temp = str[0][i];
		bool same = true;
		for (int j = 1; j < N; ++j)
		{
			if(temp != str[j][i]){
				same = false;
				break;
			}
		}
		if(same) num++;
		else break;
	}

	if(num == 0){
		printf("nai");
	}else{
		for (int i = num - 1; i >= 0; --i)
		{
			printf("%c", str[0][i]);
		}
	}
	printf("\n");
	return 0;
}

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值