1028 List Sorting (25 分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

参考代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

struct Student
{
  char id[10];
  char name[10];
  int grade;
  int ID;
}stu[100010];

bool cmp1(Student a, Student b){
  return a.ID < b.ID;
}

bool cmp2(Student a, Student b){
  int s = strcmp(a.name, b.name);
    if(s != 0){
      return s < 0;
    }else{
      return a.ID < b.ID;
    }
}

bool cmp3(Student a, Student b){
  if(a.grade != b.grade){
    return a.grade < b.grade;
  }else{
    return a.ID < b.ID;
  }
}

void get_int(Student& a){
  int num = 100000;
  for (int i = 0; i < 6; ++i)
  {
    a.ID = a.ID + (a.id[i] - '0') * num;
    num /= 10;
  }
}

int main(int argc, char const *argv[])
{
  int N,C;
  scanf("%d%d", &N, &C);
  for (int i = 0; i < N; ++i)
  {
    stu[i].ID = 0;
    scanf("%s%s%d", stu[i].id, stu[i].name, &stu[i].grade);
    get_int(stu[i]);
  }

  if(C == 1){
    sort(stu, stu + N, cmp1);
  }else if(C == 2){
    sort(stu, stu + N, cmp2);
  }else{
    sort(stu, stu + N, cmp3);
  }

  for (int i = 0; i < N; ++i)
  {
    printf("%s %s %d\n", stu[i].id, stu[i].name, stu[i].grade);
  }
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值