1085 Perfect Sequence (25 分)——3种解法(二分、two pointers)

 

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter(参数). In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

参考代码(二分法):

#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 100010;
int A[maxn];
int n, p;

int binarySearch(int i ,long long x){
    if(A[n - 1] <= x)  return n;
    int left = i + 1, right = n -1, mid;
    while(left < right){
        mid = (left + right ) / 2;
        if(A[mid] > x){
            right = mid;
        }else{
            left = mid + 1;
        }
    }
    return  left;
}

int main(){
    scanf("%d%d", &n, &p);
    for (int i = 0; i < n; ++i) {
        scanf("%d", &A[i]);
    }
    sort(A, A + n);
    int ans = 1;
    for (int j = 0; j < n; ++j) {
        int k = binarySearch(j, (long long)A[j] * p);
        ans = max(ans, k - j);
    }
    printf("%d", ans);
    return 0;
}

参考代码2(二分法):

//甲
#include<cstdio>
#include<algorithm>

using namespace std;

const int maxn = 100010;
long long A[maxn];
int n;

int main(){
    long long  p;
    scanf("%d%lld", &n, &p);
    for (int i = 0; i < n; ++i) {
        scanf("%lld", &A[i]);
    }
    sort(A, A + n);
    int ans = 1;
    for (int j = 0; j < n; ++j) {
        int k = upper_bound(A + j + 1, A + n, A[j] * p) - A;
        ans = max(ans, k - j);
    }
    printf("%d\n", ans);

    return 0;
}

参考代码3:

#include<cstdio>
#include<algorithm>
using namespace std;

typedef long long LL;
const int maxn = 100010;
int A[maxn];

int main(){
    LL n, p;
    scanf("%lld%lld", &n, &p);
    for (int i = 0; i < n; ++i) {
        scanf("%d", &A[i]);
    }
    sort(A, A + n);
    int i = 0, j =0, count = 1;
    while(j < n && i< n){
        while(j < n&& A[i] * p >= A[j]){
            count = max(count, j - i + 1);
            j++;
        }
        i++;
    }
    printf("%d\n", count);
    return  0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值