1081 Rational Sum (20 分)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line Nrational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator (分子/分母)where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional(小数) part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

思路:

简单的分数计算

参考代码:

 

#include<cstdio>
#include<algorithm>
using namespace std;

typedef long long LL;

LL gcd(LL a,LL b){
	return b == 0 ? a : gcd(b , a % b);
}

struct Fraction
{
	LL up, down;
};

Fraction reduction(Fraction result){//化简
   if(result.down < 0){//如果分母为负数
   	result.up = -result.up;
   	result.down = -result.down;
   }
   if(result.up == 0){//如果分子为0
   	result.down = 1;
   }else{
   	int d = gcd(abs(result.up),abs(result.down));//求最大公约数
   	result.up /= d;//化简
   	result.down /= d;
   }

   return result;
}

Fraction add(Fraction f1, Fraction f2){
	Fraction result;
	result.up = f1.up * f2.down + f2.up * f1.down;//分数和分子
	result.down = f1.down * f2.down;//分数和分母
	return reduction(result);//返回结果化简
}

void showResult(Fraction r){//展示结果
	reduction(r);
	if(r.down == 1)printf("%lld\n", r.up);//分母为1
	else if(abs(r.up) > r.down){//假分数
		printf("%lld %lld/%lld\n", r.up / r.down, abs(r.up) % r.down,  r.down);
	}else{//真分数
		printf("%lld/%lld\n", r.up, r.down);
	}
}

int main(){
	int n;
	Fraction sum, temp;
	//赋予初始值
	sum.up = 0;
	sum.down = 1;
	scanf("%d",&n);
	for (int i = 0; i < n; ++i)
	{
		scanf("%lld/%lld", &temp.up, &temp.down);
		sum = add(sum,temp);
	}
	showResult(sum);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值