1081 Rational Sum (20 分)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

Python:

#!/usr/bin/env python
# -*- coding: utf-8 -*-
# @Date    : 2018-02-15 18:25:00
# @Author  : 酸饺子 (changzheng300@foxmail.com)
# @Link    : https://github.com/SourDumplings
# @Version : $Id$

'''
https://www.patest.cn/contests/pat-a-practise/1081
'''


def get_gcd(a, b):
    while b:
        r = a % b
        a = b
        b = r
    return a


def simplify(nu, de):
    gcd = get_gcd(nu, de)
    return nu / gcd, de / gcd


def calc_sum(num_list):
    nu1 = int(num_list[0].split('/')[0])
    de1 = int(num_list[0].split('/')[1])
    if len(num_list) == 2:
        nu2 = int(num_list[1].split('/')[0])
        de2 = int(num_list[1].split('/')[1])
    else:
        nu2, de2 = calc_sum(num_list[1:])
    nu, de = simplify(nu1 * de2 + nu2 * de1, de1 * de2)
    return nu, de


def main():
    N = input()
    num = input().split(' ')
    nu, de = calc_sum(num)
    if nu * de < 0:
        nu = abs(nu)
        de = abs(de)
        print('-', end='')
    if nu == 0:
        print(0)
    elif nu > de:
        i = nu // de
        nu -= i * de
        print(int(i), end='')
        if nu != 0:
            print(end=' ')
        else:
            print()
    if nu != 0:
        print(int(nu), end='')
        if de != 1:
            print("/%d" % de)
        else:
            print()
    return


if __name__ == '__main__':
    main()
    # code

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值